zoukankan      html  css  js  c++  java
  • POJ 2456: Aggressive cows(二分,贪心)

                                         Aggressive cows

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 20485   Accepted: 9719

    Description

    Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

    His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

    Input

    * Line 1: Two space-separated integers: N and C 

    * Lines 2..N+1: Line i+1 contains an integer stall location, xi

    Output

    * Line 1: One integer: the largest minimum distance

    Sample Input

    5 3
    1
    2
    8
    4
    9

    Sample Output

    3

    Hint

    OUTPUT DETAILS: 

    FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

    Huge input data,scanf is recommended.

     题意

    有n个牛棚,每个牛棚的位置为a[i],m头牛,要求把这m头牛放进牛棚中,并要求这些牛之间互相间隔的距离最大,求这个最大距离

    AC代码

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    #include <limits.h>
    #include <map>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <set>
    #include <string>
    #define ll long long
    #define ull unsigned long long
    #define ms(a) memset(a,0,sizeof(a))
    #define pi acos(-1.0)
    #define INF 0x7f7f7f7f
    const double E=exp(1);
    const int maxn=1e6+10;
    const int mod=1e9+7;
    using namespace std;
    int a[maxn];
    int n,m;
    bool C(int d)
    {
    	int last=0;
    	for(int i=1;i<m;i++)
    	{
    		int crt=last+1;
    		while(crt<n&&a[crt]-a[last]<d)
    			crt++;
    		if(crt==n)
    			return false;
    		last=crt;
    	}
    	return true;
    }
    void solve()
    {
    	sort(a,a+n);
    	int lb=0;
    	int ub=INF;
    	while(ub-lb>1)
    	{
    		int mid=(lb+ub)/2;
    		if(C(mid))
    			lb=mid;
    		else
    			ub=mid;
    	}
    	cout<<lb<<endl;
    }
    int main(int argc, char const *argv[])
    {
    	ios::sync_with_stdio(false);
    	cin>>n>>m;
    	for(int i=0;i<n;i++)
    		cin>>a[i];
    	solve();
    	return 0;
    }
    
  • 相关阅读:
    长按功能实现
    html2canvas使用笔记(站在巨人的肩膀上)
    vue项目中实现复制到剪贴板的函数
    python血坑的注意点
    arcgis
    20210815_fastapi_vue看视频整理
    20210804工作总结
    文献中的优秀表达
    利用mxd文档和切片文件发布地图切片服务
    修改mxd文档的数据源并保存为特定版本
  • 原文地址:https://www.cnblogs.com/Friends-A/p/10324388.html
Copyright © 2011-2022 走看看