zoukankan      html  css  js  c++  java
  • HDU 3635:Dragon Balls(并查集)

    Dragon Balls

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 8072    Accepted Submission(s): 2991

    Problem Description

    Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 


    His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
    Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

    Input

    The first line of the input is a single positive integer T(0 < T <= 100). 
    For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
    Each of the following Q lines contains either a fact or a question as the follow format:
      T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
      Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

    Output

    For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

    Sample Input

    2
    3 3
    T 1 2
    T 3 2
    Q 2
    3 4
    T 1 2
    Q 1
    T 1 3
    Q 1

    Sample Output

    Case 1:
    2 3 0
    Case 2:
    2 2 1
    3 3 2
    

    题意

    有n个龙珠,m行操作,如果每行的第一个字母是“T”,则输入x,y表示将x地区的龙珠转移到y地区。如果第一个字母是“Q”,输入一个z,表示查询原本z地区的龙珠现在所在的地区,以及该地区的龙珠总数和z地区的龙珠一共转移了多少次

    AC代码

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    #include <limits.h>
    #include <map>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <set>
    #include <string>
    #define ll long long
    #define ms(a) memset(a,0,sizeof(a))
    #define pi acos(-1.0)
    #define INF 0x3f3f3f3f
    const double E=exp(1);
    const int maxn=1e6+10;
    using namespace std;
    int f[maxn];
    int sum[maxn];
    int ans[maxn];
    int find(int x)
    {
    	if(f[x]==-1)
    		return x;
    	int t=f[x];
    	f[x]=find(f[x]);
    	ans[x]+=ans[t];
    	return f[x];
    }
    void join(int x,int y)
    {
    	int dx=find(x);
    	int dy=find(y);
    	if(dx!=dy)
    	{
    		f[dx]=dy;
    		// 合并节点,并合并两个集合中元素转移到一个
    		sum[dy]+=sum[dx];
    		// 移动节点(一个根节点最多移动一次),这里可以使++,也可以是=1
    		ans[dx]++;
    	}
    }
    int main(int argc, char const *argv[])
    {
    	ios::sync_with_stdio(false);
    	int t;
    	int T=0;
    	int n,m;
    	char ch[2];
    	cin>>t;
    	int x,y,z;
    	while(t--)
    	{
    		ms(ans);
    		cin>>n>>m;
    		for(int i=1;i<=n;i++)
    		{
    			f[i]=-1;
    			sum[i]=1;
    			ans[i]=0;
    		}
    		cout<<"Case "<<++T<<":"<<endl;
    		while(m--)
    		{
    			cin>>ch;
    			if(ch[0]=='T')
    			{
    				cin>>x>>y;
    				join(x,y);
    			}
    			else
    			{
    				cin>>z;
    				int t=find(z);
    				cout<<t<<" "<<sum[t]<<" "<<ans[z]<<endl;
    			}
    		}
    	}
    	return 0;
    }
  • 相关阅读:
    C# Unity依赖注入
    Spring学习总结
    .Net 上传文件和下载文件
    JavaWeb学习篇--Filter过滤器
    Struts2入门教程
    Ceph 时钟偏移问题 clock skew detected 解决方案--- 部署内网NTP服务
    Erasure Coding(纠删码)深入分析 转
    s3cmd : Add a config parameter to enable path-style bucket access 当ceph rgw使用域名时,需要支持 path-style bucket特性
    ceph rgw java sdk 使用域名访问服务时需要设置s3client的配置项 PathStyleAccess 为true, 负责将报域名异常
    直播流怎么存储在Ceph对象存储上? Linux内存文件系统tmpfs(/dev/shm) 的应用
  • 原文地址:https://www.cnblogs.com/Friends-A/p/10324392.html
Copyright © 2011-2022 走看看