zoukankan      html  css  js  c++  java
  • HDU 3342:Legal or Not(拓扑排序)

                                        Legal or Not

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 10898    Accepted Submission(s): 5111

    Problem Description

    ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

    We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

    Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

    Input

    The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
    TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

    Output

    For each test case, print in one line the judgement of the messy relationship.
    If it is legal, output "YES", otherwise "NO".

    Sample Input

    3 2

    0 1

    1 2

    2 2

    0 1

    1 0

    0 0

    Sample Output

    YES

    NO

     

    题意

    给出n个人(编号0~n-1)和m对关系关系,判断有没有出现环

    AC代码

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    #include <limits.h>
    #include <map>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <set>
    #include <string>
    #define ll long long
    #define ms(a) memset(a,0,sizeof(a))
    #define pi acos(-1.0)
    #define INF 0x3f3f3f3f
    const double E=exp(1);
    const int maxn=1e3+10;
    using namespace std;
    int n,m;
    int a[maxn][maxn];
    int vis[maxn];
    void toposort()
    {
    	for(int i=0;i<n;i++)
    	{
    		for(int j=0;j<n;j++)
    		{
    			if(!vis[j])
    			{
    				vis[j]--;
    				for(int k=0;k<n;k++)
    				{
    					if(a[j][k])
    					{
    						a[j][k]--;
    						vis[k]--;
    					}
    				}
    				break;
    			}
    		}
    	}
    }
    int main(int argc, char const *argv[])
    {
    	ios::sync_with_stdio(false);
    	while(cin>>n>>m&&n&&m)
    	{
    		ms(a);
    		ms(vis);
    		int x,y;
    		for(int i=0;i<m;i++)
    		{
    			cin>>x>>y;
    			if(!a[x][y])
    			{
    				a[x][y]=1;
    				vis[y]++;
    			}
    		}
    		int flag=0;
    		toposort();
    		for(int i=0;i<n;i++)
    		{
    			for(int j=0;j<n;j++)
    				flag+=a[i][j];
    		}
    		if(flag)
    			cout<<"NO"<<endl;
    		else
    			cout<<"YES"<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    tcp/ip--百度百科
    Web service--百度百科
    .NET--百度百科
    ibatis--百度百科
    Struts2--百度百科
    spring--百度百科
    从头认识Spring-1.15 对SpEl的值的操作(1)-数值运算
    performSelector 方法的自己主动俘获特性
    图解WinHex使用入门
    LINQ使用与并行
  • 原文地址:https://www.cnblogs.com/Friends-A/p/10324416.html
Copyright © 2011-2022 走看看