zoukankan      html  css  js  c++  java
  • ZOJ 3870:Team Formation(位运算&思维)

    Team Formation

    Time Limit: 2 Seconds Memory Limit: 131072 KB

    For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

    Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).

    Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

    Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 10910^9.

    Output

    For each case, print the answer in one line.

    Sample Input

    2
    3
    1 2 3
    5
    1 2 3 4 5
    

    Sample Output

    1
    6
    

    题意

    给出一个长度为nn的序列,找到两个数,使得两个数异或后的值大于这两个数,求一共有多少对这样的数

    Solve

    两个数异或值变大的条件:较小数的最高位为1,并且较大数对应的位置为0
    将数组升序排序后,将每个数转换成二进制,找前i1i-1个数,在第ii个数的二进制形式下,有多少满足条件的数

    Code

    /*************************************************************************
    
    	 > Author: WZY
    	 > School: HPU
    	 > Created Time:   2019-04-09 19:16:39
    	 
    ************************************************************************/
    #include <bits/stdc++.h>
    #define ll long long
    #define ull unsigned long long
    #define ms(a,b) memset(a,b,sizeof(a))
    const int inf=(1<<30);
    const ll INF=(1LL*1<<60);
    const int maxn=1e6+10;
    const int mod=1e9+7;
    const int maxm=1e3+10;
    using namespace std;
    int a[maxn];
    int num[maxn];
    int cnt[maxn];
    int main(int argc, char const *argv[])
    {
    	#ifndef ONLINE_JUDGE
    	    freopen("in.txt", "r", stdin);
    	    freopen("out.txt", "w", stdout);
    	#endif
    	ios::sync_with_stdio(false);
    	cin.tie(0);
    	int t;
    	cin>>t;
    	int n;
    	while(t--)
    	{
    		ms(num,0);
    		ms(cnt,0);
    		int ans=0;
    		cin>>n;
    		for(int i=0;i<n;i++)
    			cin>>a[i];
    		sort(a,a+n);
    		for(int i=0;i<n;i++)
    		{
    			int _=0;
    			while(a[i])
    			{
    				num[_++]=a[i]&1;
    				a[i]>>=1;
    			}
    			for(int j=0;j<_;j++)
    			{
    				if(!num[j])
    					ans+=cnt[j];
    			}
    			cnt[_-1]++;
    		}
    		cout<<ans<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    通过注册表实现开机自启的取消
    数据库为什么要使用B+树
    PHP的一种缓存方案静态化
    wordpress源码阅读
    最近在搞的东西有点多Gradle,Python,java,groove搞的脑子都要炸了,还得了流感。满满的负能量。
    编写一个自己的PHP框架(一)写在前面
    cookie,session机制
    __autoload和spl_autoload_register区别
    _initialize()和__construct()
    在往数据库中插入复杂的字符串时,单双引号混用经常会搞的很乱
  • 原文地址:https://www.cnblogs.com/Friends-A/p/11054957.html
Copyright © 2011-2022 走看看