zoukankan      html  css  js  c++  java
  • ZOJ 3872: Beauty of Array(思维)

    Beauty of Array

    Time Limit: 2 Seconds Memory Limit: 65536 KB

    Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

    Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

    Output

    For each case, print the answer in one line.

    Sample Input

    3
    5
    1 2 3 4 5
    3
    2 3 3
    4
    2 3 3 2
    

    Sample Output

    105
    21
    38
    

    题意

    给定一串数字,求所有连续的子序列的和,如果一个数字出现多次,则只计算一次

    Solve

    去统计每个数字被加的次数即可,注意数据范围
    对于一个连续的序列来说,如果有重复的数字,那么后面的数字就可以忽视掉。所以对于一个数字xx,只需要去计算以这个xx为结尾和开头的序列,两者相乘即为该数字被加的次数

    Code

    /*************************************************************************
    
    	 > Author: WZY
    	 > School: HPU
    	 > Created Time:   2019-04-09 17:07:29
    	 
    ************************************************************************/
    #include <bits/stdc++.h>
    #define ll long long
    #define ull unsigned long long
    #define ms(a,b) memset(a,b,sizeof(a))
    const int inf=(1<<30);
    const ll INF=(1LL*1<<60);
    const int maxn=1e6+10;
    const int mod=1e9+7;
    const int maxm=1e3+10;
    using namespace std;
    int vis[maxn];
    int main(int argc, char const *argv[])
    {
    	#ifndef ONLINE_JUDGE
    	    freopen("in.txt", "r", stdin);
    	    freopen("out.txt", "w", stdout);
    	#endif
    	ios::sync_with_stdio(false);
    	cin.tie(0);
    	int t;
    	cin>>t;
    	int n,x;
    	ll ans;
    	while(t--)
    	{
    		ms(vis,0);
    		ans=0;
    		cin>>n;
    		for(int i=1;i<=n;i++)
    		{
    			cin>>x;
    			ans+=1LL*x*((i-vis[x])*(n-i+1));
    			vis[x]=i;
    		}
    		cout<<ans<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    【杂文】搞一个对拍程序
    【学习笔记】线段树详解(全)
    【杂文】5亿大质数表(5e8)
    【学习笔记】OI玄学道—代码坑点
    【题解】动态逆序对 [CQOI2011] [P3157] [BZOJ3295] [P1393]
    【题解】永无乡 [HNOI2012] [BZOJ2733] [P3224]
    【题解】晋升者计数 Promotion Counting [USACO 17 JAN] [P3605]
    【题解】古代猪文 [SDOI2010] [BZOJ1951] [P2480]
    【题解】PERIOD
    Navicat Premium 12连接ubuntu18 ,Mysql 5.7.27-0
  • 原文地址:https://www.cnblogs.com/Friends-A/p/11054958.html
Copyright © 2011-2022 走看看