zoukankan      html  css  js  c++  java
  • POJ 1611:The Suspects(并查集)

    The Suspects
    Time Limit: 1000MS Memory Limit: 20000K
    Total Submissions: 48327 Accepted: 23122

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    题意:有n个点和m个点集,每个点集有k个点,每个点集中的个点可以相连,求与0相连的点的个数(包括0)。

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    #include <limits.h>
    #include <map>
    #include <stack>
    #include <queue>
    #include <vector>
    #define ll long long
    #define INF 0x3f3f3f3f
    const int maxn=1e5+10;
    int a[maxn];
    int sum[maxn];
    int ans;
    int n,m;
    int k,x,y;
    int find(int x)
    {
    	if(x!=a[x])
    	{
    		return find(a[x]);
    	}
    	return a[x];
    }
    void join(int x,int y)
    {
    	int dx=find(x);
    	int dy=find(y);
    	//对dx(或dy)所在的点集进行个数统计
    	if(dx!=dy)
    	{
    		a[dy]=dx;
    		sum[dx]+=sum[dy];
    	}
    }
    int main(int argc, char const *argv[])
    {
    	while(std::cin>>n>>m&&n||m)
    	{
    		memset(a,0,sizeof(a));
    		memset(sum,0,sizeof(sum));
    		ans=1;
    		for(int i=0;i<n;i++)
    		{
    			sum[i]=1;
    			a[i]=i;
    		}
    		while(m--)
    		{
    			std::cin>>k;
    			std::cin>>x;
    			k--;
    			while(k--)
    			{
    				std::cin>>y;
    				join(x,y);
    			}
    		}
    		//输出0所在点集的个数
    		std::cout<<sum[find(0)]<<std::endl;
    	}
    	return 0;
    }
  • 相关阅读:
    IE10/IE9 Click Enter will trigger submission
    错误代码以及错误消息提示-如何更好地管理与维护消息资源
    Redmine2.6.1 升级与Agile插件安装
    编译安装的 mysql apache 用 service mysqld start 来启动
    编译安装php 5.5 缺少依赖包 及解决方案
    linux 下mysql的启动 、调试、排错
    linux 的 磁盘操作
    mysql 触发器的创建 修改 删除
    创建mysql存储过程,调用 及删除
    存储函数的创建 删除 修改
  • 原文地址:https://www.cnblogs.com/Friends-A/p/9308988.html
Copyright © 2011-2022 走看看