zoukankan      html  css  js  c++  java
  • HDU 1501 Zipper

    Zipper

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 19   Accepted Submission(s) : 10

    Font: Times New Roman | Verdana | Georgia

    Font Size:

    Problem Description

    Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.
    For example, consider forming "tcraete" from "cat" and "tree":
    String A: cat String B: tree String C: tcraete
    As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":
    String A: cat String B: tree String C: catrtee
    Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

    Input

    The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.
    For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

    Output

    For each data set, print:
    Data set n: yes
    if the third string can be formed from the first two, or
    Data set n: no
    if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

    Sample Input

    3
    cat tree tcraete
    cat tree catrtee
    cat tree cttaree
    

    Sample Output

    Data set 1: yes
    Data set 2: yes
    Data set 3: no
    

    Source

    Pacific Northwest 2004
     
    思路:DFS
     
    代码:

    #include <iostream>

    #include <cstdio>

    #include <cstring>

    using namespace std;

    int lena,lenb,lenc;

    char stra[205],strb[205],strc[405];

    int hash[205][205]; int t; int flag;

    void DFS(int a,int b,int c) {  

       //printf("%c %c %c ",stra[a],strb[b],strc[c]);    

    if(c == lenc)  

       {       

        flag = 1;       

      return ;    

    }   

      if(hash[a][b])        

        return ;    

    hash[a][b] = 1;   

      if(stra[a] == strc[c])           

    DFS(a + 1,b,c + 1);    

    if(strb[b] == strc[c])           

    DFS(a,b + 1,c + 1); }

    int main() {    

    scanf("%d",&t);

        for(int i = 1;i <= t;i ++)    

    {        

    scanf("%s%s%s",stra,strb,strc);      

       lena = strlen(stra);       

      lenb = strlen(strb);      

       lenc = strlen(strc);       

      memset(hash,0,sizeof(hash));   

          flag = 0;        

    printf("Data set %d: ",i);   

          if(lena + lenb != lenc)              

       printf("no ");     

        else    

         {           

      DFS(0,0,0);         

        if(flag)               

    printf("yes ");        

         else               

    printf("no ");

            }    

    }

    }    

  • 相关阅读:
    Magento安装教程
    让老婆爱你的十大方法。
    easy ui layout设计
    下交叉综合症
    fileloder.js+struts2实现文件异步上传,无页面刷新效果。
    将mysql中的Blob的图片在jsp中显示
    详解CSS样式的position属性
    Struts2与Spring的整合
    Play Framework常用标签list,set,如何遍历list、map类型数据
    我所理解的团队
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3290544.html
Copyright © 2011-2022 走看看