zoukankan      html  css  js  c++  java
  • HDU 1056 HangOver

    HangOver

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8072    Accepted Submission(s): 3328

    Problem Description
    How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.
     
    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
     
    Sample Input
    1.00 3.71 0.04 5.19 0.00
     
    Sample Output
    3 card(s) 61 card(s) 1 card(s) 273 card(s)
     
    Source
     
    思路:double
     
    代码:
    #include <stdio.h>
    #include <stdlib.h>
    int main()
    {

        int
    i,j,k;
        double
    s[330];
        double
    sum = 0,n;
        j = 1;
        for
    (i = 2;i < 330;i ++)
        {

            sum = sum + (double)1 / i;
            k = (int)(sum * 100);
            s[j ++] = (double)k / 100;
        }

        while
    (~scanf("%lf",&n))
        {

            for
    (i = 1;i < 330;i ++)
                  if
    (n >s[i - 1]&&n <= s[i])
                  {

                          printf("%d card(s) ",i);
                          break
    ;
                  }
       }
    }
     
  • 相关阅读:
    CMS前世今生
    叫练手把手教你读JVM之GC信息
    原来我还有网络天赋
    最简单的JVM内存结构图
    图解CyclicBarrier运动员接力赛
    图解定时任务线程池
    并发队列:ArrayBlockingQueue实际运用场景和原理
    ReentrantReadWriteLock读写锁简单原理案例证明
    JavaScript中的Function类型浅析
    JS数组整理
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3290615.html
Copyright © 2011-2022 走看看