zoukankan      html  css  js  c++  java
  • HDU 1081 To The Max

    To The Max

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6688    Accepted Submission(s): 3198


    Problem Description
    Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

    As an example, the maximal sub-rectangle of the array:

    0 -2 -7 0
    9 2 -6 2
    -4 1 -4 1
    -1 8 0 -2

    is in the lower left corner:

    9 2
    -4 1
    -1 8

    and has a sum of 15.
     
    Input
    The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
     
    Output
    Output the sum of the maximal sub-rectangle.
     
    Sample Input
    4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
     
    Sample Output
    15
     
    思路:memset(dp,0,sizeof(dp));
    memset(temp,0,sizeof(temp));
    for(int k = 1;k <= n;k ++)
    {
    for(int l = i;l <= j;l ++)
    temp[k] += map[l][k];
    }
    dp[1] = temp[1];
    for(int k = 1;k <= n;k ++){
    if(dp[k - 1] > 0)
    dp[k] = dp[k - 1] + temp[k];
    else
    dp[k] = temp[k];
    }
    for(int k = 1;k <= n;k ++)
    if(dp[k] > max)
    max = dp[k];
    }
     
    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    using namespace std;
    int map[110][110];
    int dp[110];
    int temp[110];
    int n;
    int main()
    {
    while(~scanf("%d",&n))
    {
    for(int i = 1;i <= n;i ++)
    for(int j = 1;j <= n;j ++)
    scanf("%d",&map[i][j]);
    int max = 0;
    for(int i = 1;i <= n;i ++)
    for(int j = i;j <= n;j ++)
    {
    memset(dp,0,sizeof(dp));
    memset(temp,0,sizeof(temp));
    for(int k = 1;k <= n;k ++)
    {
    for(int l = i;l <= j;l ++)
    temp[k] += map[l][k];
    }
    dp[1] = temp[1];
    for(int k = 1;k <= n;k ++){
    if(dp[k - 1] > 0)
    dp[k] = dp[k - 1] + temp[k];
    else
    dp[k] = temp[k];
    }
    for(int k = 1;k <= n;k ++)
    if(dp[k] > max)
    max = dp[k];
    }
    printf("%d ",max);
    }
    return 0;
    }

    Source
  • 相关阅读:
    站点设计
    站点规划
    自动登录百度网盘
    windows下配置Python虚拟环境
    拖拽效果
    jQuery 基础
    js操作BOM
    js操作DOM
    selenium+js自动连接Magic_WiFi
    弹框
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3313340.html
Copyright © 2011-2022 走看看