zoukankan      html  css  js  c++  java
  • HDU 1035 Robot Motion

    Robot Motion

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5274    Accepted Submission(s): 2454


    Problem Description


    A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

    N north (up the page)
    S south (down the page)
    E east (to the right on the page)
    W west (to the left on the page)

    For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

    Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

    You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
     
    Input
    There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
     
    Output
    For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
     
    Sample Input
    3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0
     
    Sample Output
    10 step(s) to exit 3 step(s) before a loop of 8 step(s)
     
    Source
     
     
    思路:无敌暴力
     
    代码:
    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    using namespace std;
    char map[12][12];
    int n,m,position;
    int timeme[12][12];
    int flag;
    int time_loop_start;
    int time_last;
    int kkkk;
    int main()
    {
        while(scanf("%d%d%d",&n,&m,&position))
        {
            if(n == 0 && m == 0 && position == 0)
                    break;
            kkkk = 1;
            memset(timeme,0,sizeof(timeme));
            time_loop_start = 0;
            for(int i = 1;i <= n;i ++){
                 getchar();
                for(int j = 1;j <= m;j ++)
                   scanf("%c",&map[i][j]);
            }
            timeme[1][position] = 1;
            flag = 0;
            int posx = 1;int posy = position;
            while(1)
            {
                int jjjj = 0;
                if(flag == 1)
                    break;
                int x = posx;int y = posy;
                if(map[posx][posy] == 'S' && jjjj == 0)
                {
                    posx = posx + 1;posy = posy;
                    jjjj = 1;
                }
                if(map[posx][posy] == 'N' && jjjj == 0)
                {
                    posx = posx - 1;posy = posy;
                    jjjj = 1;
                }
                if(map[posx][posy] == 'E' && jjjj == 0)
                {
                    posx = posx;posy = posy + 1;
                    jjjj = 1;
                }
                if(map[posx][posy] == 'W' && jjjj == 0)
                {
                    posx = posx;posy = posy - 1;
                    jjjj = 1;
                }
                if(timeme[posx][posy] >= 1)
                {
                    flag = 1;
                    time_loop_start = timeme[posx][posy];
                    time_last = timeme[x][y] + 1;
                    break;
                }
                if(posx > n || posx < 1 || posy > m || posy < 1)
                {
                    flag = 1;
                    time_last = timeme[x][y] + 1;
                    kkkk = 0;
                    break;
                }
                timeme[posx][posy] = timeme[x][y] + 1;
            }
            time_last --;
            time_loop_start --;
            if(kkkk == 0)
                printf("%d step(s) to exit ",time_last);
            else
            {
                printf("%d step(s) before a loop of %d step(s) ",time_loop_start,time_last - time_loop_start);
            }
        }
    }

  • 相关阅读:
    项目包结构
    准备dbcp2-2.1.1和pool2-2.4.2 、commons-dbcp-1.4jar包
    导入javax.servlet。伺服登记无法解决:The import javax.servlet.MultipartConfigElement cannot be resolved
    准备mysql-connector-java
    准备mybatis-spring
    准备spring
    准备MyBatis
    vim编辑器使用
    jquery怎样做出分页效果
    快速入门系列--WCF--02消息、会话与服务寄宿
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3323255.html
Copyright © 2011-2022 走看看