zoukankan      html  css  js  c++  java
  • HDU 1556 Color the ball

    Color the ball

    Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 6412    Accepted Submission(s): 3385


    Problem Description
    N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
     
    Input
    每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
    当N = 0,输入结束。
     
    Output
    每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
     
    Sample Input
    3
    1 1
    2 2
    3 3
    3
    1 1
    1 2
    1 3
    0
     
    Sample Output
    1 1 1
    3 2 1
     
    Author
    8600
     
    Source
     
    Recommend
    LL

    思路:树状数组

    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <algorithm>
    #include <cstring>
    #include <cmath>
    using namespace std;
    int map[100010];
    int n;
    int a,b;
    int lowbit(int x)
    {
    return x & (-x);
    }
    void update(int position,int number)
    {
    for(int i = position;i <= n;i += lowbit(i))
    map[i] += number;
    }
    int get(int position)
    {
    int sum = 0;
    for(int i = position;i >= 1;i -= lowbit(i))
    sum += map[i];
    return sum;
    }
    int main()
    {
    while(scanf("%d",&n),n != 0)
    {
    memset(map,0,sizeof(map));
    for(int i = 1;i <= n;i ++)
    {
    scanf("%d%d",&a,&b);
    update(a,1);update(b + 1,-1);
    }
    for(int i = 1;i < n;i ++)
    printf("%d ",get(i));
    printf("%d ",get(n));
    }
    return 0;
    }

  • 相关阅读:
    js冒泡排序
    HTML5 canvas 计时器
    centos 6.4安装杀毒软件clamAV 0.98[转]
    PHP大文件下载
    如何在 Eclipse 中使用插件构建 PHP 开发环境[转]
    CentOS 单用户模式:修改Root密码和grub加密[转]
    CentOS 6.0 VNC远程桌面配置[转]
    gprof使用介绍 (gcc -pg) [转]
    VMware NAT端口映射外网访问虚拟机linux
    shell判断文件是否存在[转]
  • 原文地址:https://www.cnblogs.com/GODLIKEING/p/3352720.html
Copyright © 2011-2022 走看看