zoukankan      html  css  js  c++  java
  • POJ 3169.Layout 最短路

    Layout
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 11612   Accepted: 5550

    Description

    Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

    Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

    Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

    Input

    Line 1: Three space-separated integers: N, ML, and MD. 

    Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

    Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

    Output

    Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

    Sample Input

    4 2 1
    1 3 10
    2 4 20
    2 3 3

    Sample Output

    27

    Hint

    Explanation of the sample: 

    There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

    The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
    题意:有n头牛按编号顺序站一排,即每头牛都有一个一维坐标,可以相同。现在有一些牛之间有关系,关系好的a,b必须距离小于等于dl;关系不好的a,b必须距离大于等于dd。求牛1和牛n的最大距离。
    思路:最短路问题:<u,v> d[u]+d>=d[v]。
    n头牛按编号顺序站一排,则d[i+1]>=d[i],即编号大的牛的坐标大于等于编号小的牛。关系好的牛a,牛b,则d[a]+d>=d[b];关系不好的牛a,牛b,则d[a]+d<=d[b],即d[b]+(-d)>=d[a]。求约束下的最大距离。最短路也可以理解为约束下的最大解。
    因为存在负权值,所以有可能存在负权值回路,所以dijkstra算法不能使用,直接使用ford算法。存在负权值回路输出-1,d[n]=inf输出-2,其他情况直接输出d[n]。
    代码:
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstring>
    #include<algorithm>
    #include<map>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<set>
    using namespace std;
    typedef pair<int,int> P;
    typedef long long ll;
    const int maxn=1e5+100,inf=0x3f3f3f3f,mod=1e9+7;
    const ll INF=1e13+7;
    struct edge
    {
        int from,to;
        int cost;
    };
    int cou=0;
    edge es[maxn];
    vector<edge>G[maxn];
    int used[maxn];
    priority_queue<P,vector<P>,greater<P> >que;
    void addedge(int u,int v,int w)
    {
        cou++;
        edge e;
        e.from=u,e.to=v,e.cost=w;
        es[cou].from=u,es[cou].to=v,es[cou].cost=w;
        G[u].push_back(e);
    }
    int n,ml,md;
    int al[maxn],bl[maxn],dl[maxn];
    int ad[maxn],bd[maxn],dd[maxn];
    int d[maxn];
    void ford()
    {
        for(int i=1; i<=n; i++) d[i]=inf;
        d[1]=0;
        for(int t=1; t<n; t++)
        {
            for(int i=1; i<n; i++)
                if(d[i+1]<inf) d[i]=min(d[i],d[i+1]);
            for(int i=1; i<=ml; i++)
                if(d[al[i]]<inf) d[bl[i]]=min(d[bl[i]],d[al[i]]+dl[i]);
            for(int i=1; i<=md; i++)
                if(d[bd[i]]<inf)  d[ad[i]]=min(d[ad[i]],d[bd[i]]-dd[i]);
        }
        if(d[1]<0) cout<<-1<<endl;
        else if(d[n]>=inf) cout<<-2<<endl;
        else cout<<d[n]<<endl;
    }
    int main()
    {
        int a,b,d;
        scanf("%d%d%d",&n,&ml,&md);
        for(int i=1; i<n; i++) addedge(i+1,i,0);
        for(int i=1; i<=ml; i++)
            scanf("%d%d%d",&al[i],&bl[i],&dl[i]);
        for(int i=1; i<=md; i++)
            scanf("%d%d%d",&ad[i],&bd[i],&dd[i]);
        ford();
        return 0;
    }
    /*
    4 3 0
    1 3 10
    2 4 20
    2 3 3
    */
    最短路
    I am a slow walker,but I never walk backwards.
  • 相关阅读:
    Java核心API需要掌握的程度
    JAVA开发者最常去的20个英文网站
    Java .class files decompile tools
    让aptget到网络上查找源,避免经常插入光盘
    Google Job : Research Engineer Beijing
    教你亚健康该如何饮食
    tcpdump w 和 r 的使用
    黑客发布iOS 4.1永久越狱程序 狼人:
    微软将迎来迄今最大补丁日 一次修补49个漏洞 狼人:
    百度瞄准客户端 迅雷、360、腾讯皆是目标 狼人:
  • 原文地址:https://www.cnblogs.com/GeekZRF/p/7069514.html
Copyright © 2011-2022 走看看