zoukankan      html  css  js  c++  java
  • Score, ACM/ICPC Seoul 2005, UVa 1585

                                             Score

    Description

    There is an objective test result such as ``OOXXOXXOOO". An `O' means a correct answer of a problem and an `X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive `O's only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O's.Therefore, the score of ``OOXXOXXOOO" is 10 which is calculated by ``1+2+0+0+1+0+0+1+2+3".You are to write a program calculating the scores of test results.

    Input

    Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by ` O' and ` X' and the length of the string is more than 0 and less than 80. There is no spaces between ` O' and ` X'.

    Output 

    Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.The following shows sample input and output for five test cases.

    Sample Input 

    5 
    OOXXOXXOOO 
    OOXXOOXXOO 
    OXOXOXOXOXOXOX 
    OOOOOOOOOO 
    OOOOXOOOOXOOOOX
    

    Sample Output 

    10 
    9 
    7 
    55 
    30
    当累加器遇到‘X’时,重置为零。

    #include<iostream>
    #include<cstring>
    using namespace std;
    int main()
    {
        int t;
        cin>>t;
        while( t-- )
        {
            char str[81];
            int sum = 0, count = 0;
            cin>>str;
            int length = strlen(str);
            for( int i=0; i<length; i++ )
            {
                if( str[i] == 'O' )
                {
                    count++;
                    sum += count;
                }
                else
                    count = 0;
            }
            cout<<sum<<endl;
        }
        return 0;
    }



  • 相关阅读:
    CSS 选择器
    CSS 用法和特性
    Objective-C 事件响应链
    苹果签名机制
    欧几里得算法
    扩展欧几里得算法
    RSA算法
    动态库加载和代码签名
    __attribute__
    信息熵
  • 原文地址:https://www.cnblogs.com/Genesis2018/p/8304843.html
Copyright © 2011-2022 走看看