zoukankan      html  css  js  c++  java
  • Max Sum 贪心

                                                                                                                        Max Sum

    Description

    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
     

    Input

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
     

    Output

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
     

    Sample Input

    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     

    Sample Output

    Case 1: 14 1 4 Case 2: 7 1 6
     

    #include<iostream>
    using namespace std;
    int a[100000];
    void maxSubSum(int a[], int n){
        int maxSum=-1001, thisSum=-1001, start=0, end=0, p=0;
        for(int i=0; i<n; i++){
            if(thisSum + a[i] <a[i]){
                thisSum = a[i];
                p = i;
            }
            else  thisSum += a[i];
            if(thisSum > maxSum){
                maxSum = thisSum;
                start = p;
                end = i;
            }
        }
        cout<<maxSum<<" "<<start+1<<" "<<end+1<<endl;
    }
    int main(){
        int t, i;
        cin>>t;
        for(i=1; i<=t; i++){
            int n;
            cin>>n;
            for(int j=0; j<n; j++)  cin>>a[j];
            if(i!=1)  cout<<endl;
            cout<<"Case "<<i<<":"<<endl;
            maxSubSum(a, n);
        }
        return 0;
    }


  • 相关阅读:
    cocos2d-x3.x Vector
    CC_CALLBACK之间的区别
    android平台菜单返回键监听
    更方便的函数回调——Lambda
    MySQL 多实例启动和关闭脚本
    ERROR 23 (HY000) at line 29963: Out of resources when opening file
    [ERROR] Failed to open log
    ERROR 1005 (HY000): Can't create table'matrix.system_log' (errno: 150)
    show engine innodb statusG
    【转载】mysql 四种隔离级别分析
  • 原文地址:https://www.cnblogs.com/Genesis2018/p/9079894.html
Copyright © 2011-2022 走看看