zoukankan      html  css  js  c++  java
  • POJ:1862-Stripies

    Stripies

    Time Limit: 1000MS Memory Limit: 30000K
    Total Submissions: 19144 Accepted: 8562

    Description

    Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn’t equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
    You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

    Input

    The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

    Output

    The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

    Sample Input

    3
    72
    30
    50

    Sample Output

    120.000


    解题心得:

    1. 题意就是有n个细菌,每个细菌有一个自己的体重,细菌可以两两融合,每次融合之后生成一个新的细菌,体重是2*sqrt(a*b),问要怎么融合使最后合成的细菌体重最小。
    2. 这里写图片描述
      根据这个公式,每次细菌合成体重都会变小,变小的比例是不变的,所以要先选体重大的细菌来合成,然后按照比例缩小这样减小的体重会更多。这样就可以使用优先队列,模仿写哈夫曼树的权值和的方法来写就行了。

    #include <stdio.h>
    #include <queue>
    #include <math.h>
    using namespace std;
    int main() {
        int n;
        priority_queue <double > qu;
        scanf("%d",&n);
        for(int i=0;i<n;i++) {
            double temp;
            scanf("%lf",&temp);
            qu.push(temp);
        }
    
        while(!qu.empty()) {
            double a,b;
            a = qu.top(); qu.pop();
            if(qu.empty()) {
                printf("%.3f",a);
                break;
            }
            b = qu.top(); qu.pop();
            double c = 2*sqrt(a*b);
            qu.push(c);
        }
        return 0;
    }
  • 相关阅读:
    Netty实现原理浅析
    Netty
    JAVA调用Rest服务接口
    泛型约束
    RegisterStartupScript和RegisterClientScriptBlock的用法
    TFS 2010 使用手册(四)备份与恢复
    TFS 2010 使用手册(三)权限管理
    TFS 2010 使用手册(二)项目集合与项目
    TFS 2010 使用手册(一)安装与配置
    错误"Lc.exe 已退出,代码 -1 "
  • 原文地址:https://www.cnblogs.com/GoldenFingers/p/9107153.html
Copyright © 2011-2022 走看看