zoukankan      html  css  js  c++  java
  • POJ:2431-Expedition

    Expedition

    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 20089 Accepted: 5786

    Description

    A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck’s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

    To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

    The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

    Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

    Input

    • Line 1: A single integer, N

    • Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

    • Line N+2: Two space-separated integers, L and P

    Output

    • Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

    Sample Input

    4
    4 4
    5 2
    11 5
    15 10
    25 10

    Sample Output

    2

    Hint

    INPUT DETAILS:

    The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

    OUTPUT DETAILS:

    Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.


    解题心得

    1. 做这个题是看了挑战那本书才来做的题,结果只是考了一个很简单的思维问题,但是被poj上的题目描述和挑战那本书的题目描述给弄晕了,poj是反着描述的,但是挑战那本书是正向描述的。sad。
    2. 怎么解题挑战那本书上面说的很清楚了就不多说了。

    #include <stdio.h>
    #include <cstring>
    #include <queue>
    #include <algorithm>
    using namespace std;
    const int maxn = 1e4+100;
    int l,now,res,n;
    struct NODE {
        int va,pos;
        friend bool operator < (const NODE a,const NODE b){
            return a.pos < b.pos;
        }
    }node[maxn];
    
    void init() {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d%d",&node[i].pos,&node[i].va);
        scanf("%d%d",&l,&res);
        node[n].va = 0;
        node[n].pos = l;
        for(int i=0;i<n;i++)
            node[i].pos = l - node[i].pos;//反向输入的位置给弄正
    
        sort(node,node+n+1);
        now = 0;
    }
    
    void solve() {
        int ans = 0;
        priority_queue <int> qu;
    
        for(int i=0;i<=n;i++) {
            int dis = node[i].pos - now;
            while(dis > res) {
                if(qu.empty()){
                    printf("-1");
                    return ;
                }
                res += qu.top();
                ans++;
                qu.pop();
            }
            qu.push(node[i].va);
            now = node[i].pos;
            res -= dis;
        }
        printf("%d",ans);
    }
    
    int main() {
        init();
        solve();
        return 0;
    }
    
    
  • 相关阅读:
    变量与常量
    velocity基本用法
    jboss之mod_cluster集群
    jboss部署出现MarshalOutputStream找不到错误
    redis--安装
    java-基础
    jboss使用(eap 6.0以后版本)
    ZooKeeper安装
    linux-redhat5找回root密码
    发布JavaWeb项目时如何将本地lib下的架包发布到服务器上
  • 原文地址:https://www.cnblogs.com/GoldenFingers/p/9107162.html
Copyright © 2011-2022 走看看