zoukankan      html  css  js  c++  java
  • map函数的应用:UVa156-Ananagrams

    Ananagrams

    Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

    Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

    Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.

    Input

    Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line consisting of a single ‘#’.

    Output

    Output will consist of aseries of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive)order. There will always be at least one relative ananagram.

    Sample Input

    ladder came tape soon leader acme RIDE lone Dreis peat
    ScAlE orb eye Rides dealer NotE derail LaCeS drIed
    noel dire Disk mace Rob dries

    Sample Output

    Disk
    NotE
    derail
    drIed
    eye
    ladder
    soon


    解题心得

    1. 考察map和set应用的一道题,很简单,因为不区分大小写,所以可以先将string中的所有大写转换成小写,然后sort将string排个序,排好序的string映射一下。最后再重复找一遍就可以了。

    #include<bits/stdc++.h>
    using namespace std;
    map<string,int> Map;
    set <string> se2;
    int main()
    {
        string s;
        while(cin >> s)
        {
            if(s == "#")
                break;
            string s1 = s;
            for(string::iterator iter = s1.begin();iter!=s1.end();iter++)
                *iter = tolower(*iter);
            sort(s1.begin(),s1.end());
            Map[s1]++;//先将所有的string小写转换,排序,映射一下;
            se2.insert(s);//记录本身的单词
        }
    
        for(set<string> :: iterator iter=se2.begin();iter!=se2.end();iter++)
        {
            string k = *iter;
            for(string::iterator iter1=k.begin();iter1!=k.end();iter1++)
                *iter1 = tolower(*iter1);
            sort(k.begin(),k.end());
            if(Map[k] == 1)//单词只出现过一次即符合条件
                cout<<*iter<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    【java】一维数组循环位移方阵
    【java】for循环输出数字金字塔
    C++编程tips
    C++中cin.get 和cin.peek 及其相关的用法
    ubuntu增加字符设备驱动程序/ 操作系统课程设计
    C++ Primer 学习笔记/ 处理类型
    C++学习,顶层const
    C++学习笔记/const和指针
    ubuntu16.04增加系统调用(拷贝)
    Java学习笔记#数组 循环遍历
  • 原文地址:https://www.cnblogs.com/GoldenFingers/p/9107269.html
Copyright © 2011-2022 走看看