zoukankan      html  css  js  c++  java
  • set的应用:UVa10815-Andy's First Dictionary

    Andy’s First Dictionary

    Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful. You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.
    这里写图片描述

    Input

    The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

    Output

    Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

    Sample Input

    Adventures in Disneyland

    Two blondes were going to Disneyland when they came to a fork in the road. The sign read: “Disneyland Left.”

    So they went home.

    Sample Output

    a
    adventures
    blondes
    came
    disneyland
    fork
    going
    home
    in
    left
    read
    road
    sign
    so
    the
    they
    to
    two
    went
    were
    when


    解题思路:

    1. 就是很简单的一个set的应用,题意是给你一篇文章,让你输出里面有多少个不同的单词,主要是处理一下里面的标点符号,然后裸的set就可以过了。
    2. 里面的用了三个库函数,isalpha(char)如果是字母返回true,不然返回false。tolower(char)把一个字母转换成小写字母。stringstream ss(string)将一个string类型输入到ss之中。有点像c中的sprintf;

    #include<bits/stdc++.h>
    using namespace std;
    set <string> se;
    string s;
    int main()
    {
        while(cin>>s)
        {
            string::iterator iter1;
            string s1;
            for(iter1=s.begin();iter1!=s.end();iter1++)
            {
                if(isalpha(*iter1))
                    *iter1 = tolower(*iter1);
                else
                    *iter1 = ' ';
            }
            stringstream ss(s);//这里要转换一下,如果标点符号在中间可能形成两个单词
            while(ss >> s1)
                se.insert(s1);
            s.clear();
        }
        set <string> :: iterator iter;
        for(iter=se.begin();iter!=se.end();iter++)
            cout<<*iter<<endl;
        return 0;
    }
    
  • 相关阅读:
    前端vue使用js-xlsx导出excel的三种方法
    vue使用echarts绘制河南地图并实现个人轨迹
    VUE中使用Echarts绘制柱状图
    springboot项目配置拦截器
    springboot+mybatis的多数据源配置
    Java后端高频面试题汇总
    Java基础专题
    Java集合专题
    Java并发专题
    JVM专题javascript:;
  • 原文地址:https://www.cnblogs.com/GoldenFingers/p/9107270.html
Copyright © 2011-2022 走看看