zoukankan      html  css  js  c++  java
  • ACM : POJ 2676 SudoKu DFS

    Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

    Description

    Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

    Input

    The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

    Output

    For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

    Sample Input

    1
    103000509
    002109400
    000704000
    300502006
    060000050
    700803004
    000401000
    009205800
    804000107

    Sample Output

    143628579
    572139468
    986754231
    391542786
    468917352
    725863914
    237481695
    619275843
    854396127


    /*/
    数独
    
    AC代码:
    /*/
    #include"iostream"
    #include"cstdio"
    #include"cstring"
    #include"queue"
    #include"string"
    using namespace std;
    int map[11][11],count,n;
    bool F[11][11];
    bool H[11][11];
    bool L[11][11];
    
    struct Node {
    	int x,y;
    } node[100];
    
    int MAP(int i,int j) {
    	if(i<=3&&j<=3)return 1;
    	else if(i<=3&&j<=6)return 2;
    	else if(i<=3&&j<=9)return 3;
    	else if(i<=6&&j<=3)return 4;
    	else if(i<=6&&j<=6)return 5;
    	else if(i<=6&&j<=9)return 6;
    	else if(i<=9&&j<=3)return 7;
    	else if(i<=9&&j<=6)return 8;
    	else if(i<=9&&j<=9)return 9;
    }
    
    int  DFS(int n) {
    	if(n>count) {
    		return 1;
    	}
    	for(int j=1; j<=9; j++) {
    		if(!H[node[n].x][j]&&!L[node[n].y][j]&&!F[MAP(node[n].x,node[n].y)][j]) {
    			H[node[n].x][j]=L[node[n].y][j]=F[MAP(node[n].x,node[n].y)][j]=1;
    			map[node[n].x][node[n].y]=j;
    			if(DFS(n+1))return 1;
    			H[node[n].x][j]=L[node[n].y][j]=F[MAP(node[n].x,node[n].y)][j]=0;
    		}
    	}
    	return 0;
    }
    
    
    int main() {
    	int flag=0;
    	while(cin>>n) {
    		for(int i=1; i<=n; i++) {
    			memset(map,0,sizeof(map));
    			memset(H,0,sizeof(H));
    			memset(F,0,sizeof(F));
    			memset(L,0,sizeof(L));
    			count = 0;
    			for(int j=1; j<=9; j++)
    				for(int k=1; k<=9; k++) {
    					scanf("%1d",&map[j][k]);
    					if(map[j][k]==0) {
    						count++;
    						node[count].x=j;
    						node[count].y=k;
    					} else {
    						H[j][map[j][k]]=1;
    						L[k][map[j][k]]=1;
    						F[MAP(j,k)][map[j][k]]=1;
    					}
    				}
    			DFS(1);
    			for(int j=1; j<=9; j++) {
    				for(int k=1; k<=9; k++)
    					cout<<map[j][k];
    				cout<<endl;
    			}
    
    		}
    	}
    	return 0;
    }
    
    
    
  • 相关阅读:
    VSCODE打开一个文件,另一个文件就关闭的问题的解决方法
    elementui的el-tree第一次加载无法展开和选中的问题
    Java线程知识:二、锁的简单使用
    “商家参数格式有误”应用切微信H5支付完美解决方案
    git 基础操作,公私钥认证/ssh公私钥登录
    Python数据分析之亚马逊股价
    Python分析6000家破产IT公司
    Python数据分析之股票数据
    Python数据分析之全球人口数据
    Vue 面试重点真题演练
  • 原文地址:https://www.cnblogs.com/HDMaxfun/p/5869199.html
Copyright © 2011-2022 走看看