zoukankan      html  css  js  c++  java
  • Poj Maya Calendar

    http://poj.org/problem?id=1008
     

    Maya Calendar

    Time Limit: 1000MS
    Memory Limit: 10000K
    Total Submissions: 64607
    Accepted: 19908

    Description

    During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.

    For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.

    Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:

    1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .

    Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:

    Haab: 0. pop 0

    Tzolkin: 1 imix 0
    Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.

    Input

    The date in Haab is given in the following format:
    NumberOfTheDay. Month Year

    The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.

    Output

    The date in Tzolkin should be in the following format:
    Number NameOfTheDay Year

    The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.

    Sample Input

    3 10. zac 0 0. pop 0 10. zac 1995

    Sample Output

    3 3 chuen 0 1 imix 0 9 cimi 2801
    总的思路是首先计算出给出的Haab 历表示的日期是世界开始后的第几天(假设是k),
    然后用k 除以260 得到Tzolkin 历的年份,再用k 对260 取模得到m,用m 分别对13 和20
    取模得到d 和s,d 和Tzolkin 历中第s 个字符串的组合就是要求的日期。这里需要注意的是
    如果我们把世界的第1 天用0 表示,第260 天用259 表示,则正好用这个数字除以260 得到
    Tzolkin 历的年份,m 对13 取模后得到0 到12 的值,这个值要加1 才能用于表示Tzolkin
    历的日期,同时m 对20 取模后得到0~19 的数值,分别表示取20 个字符串中的一个。如果
    我们用字符串数组来存储这20 个字符串,则0~19的取值正好对应需要的字符串的数组下标。

    Codes:
     1 #include<stdio.h>
     2 #include<string.h>
     3 #define max 10
     4 char H_month[19][max]={"pop","no","zip","zotz","tzec","xul","yoxkin","mol","chen","yax","zac","ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"};
     5 char T_month[20][max]={"imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk","ok","chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"};
     6 int main(){
     7         int n,i;
     8         scanf("%d",&n);
     9         printf("%d ",n);
    10         while(n--){
    11             int day,dates,year;
    12             char month[max];
    13             scanf("%d. %s %d",&day,month,&year);
    14             for(i=0;i<19;i++)
    15                 if(!strcmp(H_month[i],month)) break;
    16                 dates=year*365+i*20+day;
    17             printf("%d %s %d ",1+dates%13,T_month[dates%20],dates/260);
    18         }
    19 }
  • 相关阅读:
    Palindrome
    Girls' research
    最长回文
    Water Tree
    Alternating Current
    Psychos in a Line
    Feel Good
    Color the Fence
    javaScript内置类Date,Math等
    DOM之兄弟节点
  • 原文地址:https://www.cnblogs.com/HRuinger/p/3741819.html
Copyright © 2011-2022 走看看