zoukankan      html  css  js  c++  java
  • POJ 1860 Currency Exchange 最短路+负环

    原题链接:http://poj.org/problem?id=1860

    Currency Exchange
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 23055   Accepted: 8328

    Description

    Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
    For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
    You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
    Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

    Input

    The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103
    For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102
    Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104

    Output

    If Nick can increase his wealth, output YES, in other case output NO to the output file.

    Sample Input

    3 2 1 20.0
    1 2 1.00 1.00 1.00 1.00
    2 3 1.10 1.00 1.10 1.00
    

    Sample Output

    YES

    Source

    Northeastern Europe 2001, Northern Subregion

    题意

    给你多种货币之间的兑换关系,现在你有若干某种货币,问你是否能够通过不断兑换,使得你的这种货币变多。

    题解

    如果存在某个环,使得你在这个环上跑一圈钱变多了,并且这个环可以由起点到达,那么你就可以在这个环上一直跑,知道钱变得无穷大,然后再回到起点,那么此时你的钱就肯定变多了。所以问题就转换为了,在这个图上是否存在这样的环,我们发现,这和负环的性质十分相似。那么可以得出以下算法,通过spfa遍历图,每次从队首取出元素去松弛各个节点的当前值,这里的松弛和最短路相反,定义松弛成功为当前值变大。如果松弛成功且节点没在队中,那么入队。如果某个节点入队的次数大于n,那么这个节点一定是某个钱变多的环上的节点。

    代码

    #include<iostream>
    #include<cstring>
    #include<vector>
    #include<string>
    #include<queue>
    #include<algorithm>
    #define MAX_N 123
    using namespace std;
    
    struct edge {
    public:
        int to;
        double r, c;
    
        edge(int t, double rr, double cc) : to(t), r(rr), c(cc) { }
    
        edge() { }
    };
    
    vector<edge> G[MAX_N];
    int N,M,S;
    double V;
    
    queue<int> que;
    bool inQue[MAX_N];
    double d[MAX_N];
    int cnt[MAX_N];
    
    bool spfa() {
        que.push(S);
        inQue[S] = 1;
        d[S] = V;
        cnt[S]++;
        while (que.size()) {
            int u = que.front();
            que.pop();
            inQue[u] = 0;
            for (int i = 0; i < G[u].size(); i++) {
                int v = G[u][i].to;
                double r = G[u][i].r, c = G[u][i].c;
                if ((d[u] - c) * r > d[v]) {
                    d[v] = (d[u] - c) * r;
                    if (!inQue[v]) {
                        que.push(v);
                        inQue[v] = 1;
                        cnt[v]++;
                        if (cnt[v] > N)return true;
                    }
                }
            }
        }
        return false;
    }
    
    int main() {
        cin.sync_with_stdio(false);
        cin >> N >> M >> S >> V;
        for (int i = 0; i < M; i++) {
            int u, v;
            double r, c;
            cin >> u >> v >> r >> c;
            G[u].push_back(edge(v, r, c));
            cin >> r >> c;
            G[v].push_back(edge(u, r, c));
        }
        if (spfa())cout << "YES" << endl;
        else cout << "NO" << endl;
    
        return 0;
    }
  • 相关阅读:
    SSH框架中使用注解和xml配置的区别
    web项目中log4j的配置
    嵌入式—ASCII码
    MATLAB
    MATLAB
    MATLAB
    MATLAB
    CentOS 7将网卡名称eno16777736改为eth0
    图像增强处理
    Debussy与modelsim联仿时 do 文件脚本
  • 原文地址:https://www.cnblogs.com/HarryGuo2012/p/4754493.html
Copyright © 2011-2022 走看看