zoukankan      html  css  js  c++  java
  • HDU 1059 Dividing【多重背包】

    Problem Description
    Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
    Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
     

    Input
    Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

    The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
     

    Output
    For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

    Output a blank line after each test case.
     

    Sample Input
    1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
     

    Sample Output
    Collection #1:
    Can't be divided.
    Collection #2:
    Can be divided.
     

    ‘思路

    题目大意:分割价值为i的数量为v[i]的石头为两份;

    方法;若石头的总价值sum为奇数那么石头可定不能分割;若石头的价格为偶数,接下来把它转化为简单的01背包问题,判断是否可以组成价值为sum/2的情况。

    对于第i个物品,若前i-1个能装满容量为k的背包,那么前i个物品就能装满容量为k+w[i]的背包。那么如果f[i-w[i]]为true,那么f[i]也为true。

    源码

    #include<stdio.h>

    #include<string.h>

    #include<iostream>

    using namespace std;

    int main()

    {

        int a[10], i, vau[1005], f[100000], times=0, j;

        while(scanf("%d%d%d%d%d%d", &a[1], &a[2], &a[3], &a[4], &a[5], &a[6])!=EOF)

        {

            times++;

            if(a[1]==0&&a[2]==0&&a[3]==0&&a[4]==0&&a[5]==0&&a[6]==0)

                break;

            else

            {

                printf("Collection #%d:\n", times);

                memset(vau, 0, sizeof(vau));

                memset(f, 0, sizeof(f));

                int t=0, sum=0;

                f[0]=1;

                for(i=1; i<=6; i++)

                {

                    sum+=i*a[i];

                    int j=1;

                    while(a[i]>=j)

                    {

                        vau[t++]=j*i;

                        a[i]-=j;

                        j*=2;

                    }

                    if(a[i]>0)

                        vau[t++]=a[i]*i;

                }

                if(sum%2==1)

                    printf("Can't be divided.\n");

                else

                {

                    for(i=0; i<t; i++)

                        for(j=sum/2; j>=vau[i]; j--)

                        {

                            if(f[j-vau[i]])

                                f[j]=1;

                        }

                    if(f[sum/2])

                        printf("Can be divided.\n");

                    else

                        printf("Can't be divided.\n");

                }

                printf("\n");

            }

        }

    }

     
  • 相关阅读:
    Heavy Transportation POJ
    Frogger POJ
    CODEFORCES 25E Test
    POJ
    POJ-2777
    [ZJOI2008]骑士
    POJ
    POJ
    [USACO12FEB]Nearby Cows
    [HAOI2009]毛毛虫
  • 原文地址:https://www.cnblogs.com/Hilda/p/2616938.html
Copyright © 2011-2022 走看看