zoukankan      html  css  js  c++  java
  • HDU 1506 Largest Rectangle in a Histogram【矩阵最大面积】

    Problem Description
    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
     
    Input
    The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
     
    Output
    For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
     
    Sample Input
    7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
     
    Sample Output
    8 4000
     

    思路

    题目大意:就是求最大的矩形面积。

    解决方法:把i前面大于等于它的数下标记下来left[],把它后面比他大的数的下标记下来right[],在一次比较面积的大小。

    源码

    #include<stdio.h>

    #include<string.h>

    __int64 h[100005], left[100005], right[100005];

    int main()

    {

        int i, j, k, n, temp;

        while(scanf("%d", &n)==1&&n)

        {

            memset(h, 0, sizeof(h));

            memset(left, 0, sizeof(left));

            memset(right, 0, sizeof(right));

            for(i=1; i<=n; i++)

            {

                scanf("%I64d", &h[i]);

                left[i]=right[i]=i;

            }

            for(i=2; i<=n; i++)

            {

                temp=i;

                while(h[temp-1]>=h[i]&&temp>1)

                    temp=left[temp-1];

                left[i]=temp;

            }

            for(i=n-1; i>0; i--)

            {

                temp=i;

                while(h[temp+1]>=h[i]&&temp<n)

                    temp=right[temp+1];

                right[i]=temp;

            }

            __int64 area=0;

            for(i=1; i<=n; i++)

            {

                if((__int64)((right[i]-left[i]+1)*h[i])>area)

                    area=(right[i]-left[i]+1)*h[i];

            }

            printf("%I64d\n", area);

        }

    }

  • 相关阅读:
    CodeForces 785D Anton and School
    CodeForces 785C Anton and Fairy Tale
    CodeForces 785B Anton and Classes
    CodeForces 785A Anton and Polyhedrons
    爱奇艺全国高校算法大赛初赛C
    爱奇艺全国高校算法大赛初赛B
    爱奇艺全国高校算法大赛初赛A
    EOJ 3265 七巧板
    EOJ 3256 拼音魔法
    EOJ 3262 黑心啤酒厂
  • 原文地址:https://www.cnblogs.com/Hilda/p/2616963.html
Copyright © 2011-2022 走看看