zoukankan      html  css  js  c++  java
  • POJ 1469 COURSES【最大匹配】

    Description

    Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

    • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
    • each course has a representative in the committee

    Input

    Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

    P N
    Count1 Student1 1 Student1 2 ... Student1 Count1
    Count2 Student2 1 Student2 2 ... Student2 Count2
    ...
    CountP StudentP 1 StudentP 2 ... StudentP CountP

    The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
    There are no blank lines between consecutive sets of data. Input data are correct.

    Output

    The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

    Sample Input

    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1

    Sample Output

    YES
    NO

    #include<stdio.h>   
    #include<string.h>
    #include<iostream>
    using namespace std; 
    #define course_max 101
    #define stud_max 301
    int used[stud_max];  //记录是否被扫描过 
    int link[stud_max];     //记录与学生关联的元素 
    int map[course_max][stud_max];    //学生j选择的课程i 
    int coursenum, studnum; 
    int DFS(int t)
    {
        int i;
        for(i=0; i<studnum; i++)  //对于y中所有顶点i 
        {
            if(!used[i]&&map[t][i])      //顶点i未使用过, 并且t与i有相连的边 
            {
                used[i]=1;        //顶点i标记为使用过 
                if(link[i]==-1||DFS(link[i])) //如果i没有被标记过的边连到t 
                {            //或者i与x中的顶点link[i]构成的边被标记但x的顶点link[i]可增光 
                    link[i]=t;            //修改标记方式,使得顶点t与i构成的边被标记 
                    return 1;            //说明可以增广 
                }
            }
        }
        return 0;
    } 
    int main()
    {
        int T, i, n, nn, x, j;
        scanf("%d", &T);
        while(T--)
        { 
            scanf("%d%d", &coursenum, &studnum);
            memset(link, -1, sizeof(link));
            memset(map, 0, sizeof(map));
            for(i=0; i<coursenum; i++)
            {
                scanf("%d", &nn);
                for(j=0; j<nn; j++)
                {
                    scanf("%d", &x);
                    map[i][x-1]=1;
                }
            }
            int num=0; 
            for(i=0; i<coursenum; i++)    //选择一个顶点i 
            {
                memset(used, 0, sizeof(used));    //左边 x中所有顶点标记为未使用过 
                if(DFS(i))    //如果i可以增广 皮配数+1 
                    num++;
            }
            if(num==coursenum)
                printf("YES\n");
            else
                printf("NO\n");
        }
        return 0;
    }                 
  • 相关阅读:
    (LeetCode 141/142)Linked List Cycle
    (算法)随机播放歌曲
    (数组)数组排序,使所有奇数在左边,所有偶数在右边
    遗失的乔布斯访谈(文字版)
    幻想·梦想·理想
    立刻辞职,时不我待
    彩票漏洞让你快速致富
    剪刀石头布常胜秘笈
    9个心理学研究,让你学习更高效
    石头剪刀布手套:不止是寂寞宅的消遣
  • 原文地址:https://www.cnblogs.com/Hilda/p/2617552.html
Copyright © 2011-2022 走看看