zoukankan      html  css  js  c++  java
  • POJ 2001 Shortest Prefixes【第一棵字典树】

    Description

    A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

    In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

    An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

    Input

    The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

    Output

    The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

    Sample Input

    carbohydrate
    cart
    carburetor
    caramel
    caribou
    carbonic
    cartilage
    carbon
    carriage
    carton
    car
    carbonate
    

    Sample Output

    carbohydrate carboh
    cart cart
    carburetor carbu
    caramel cara
    caribou cari
    carbonic carboni
    cartilage carti
    carbon carbon
    carriage carr
    carton carto
    car car
    carbonate carbona

    题意:就是找出所给的单词的独一无二的前缀,并且保证最短...
    思路:字典树实现
    代码如下:
    #include<string.h>
    #include<stdio.h>
    #include<stdlib.h>
    char ch[1005][25]; 
    struct node
    {
        int cnt;
         node *next[27];
    }*root; 
    void Maketree(char *str)
    {
        int ans, i, len;
        node *p, *q;
        p=root; 
        len=strlen(str); 
        for(i=0; i<len; i++)
        {
            ans=str[i]-'a';
            if(p->next[ans]!=NULL)
            {
                p=p->next[ans];
                p->cnt++;
            }
            else
            {
                q=(node *)calloc(1, sizeof(node));
                p->next[ans]=q;
                p=q;
                p->cnt=1;
            }
        }
    }
    void Findtree(char *str)
    {
         int i, len, ans;
         node *p;
         p=root; 
         len=strlen(str); 
         for(i=0; i<len; i++)
         {
               ans=str[i]-'a';
             p=p->next[ans];
             printf("%c", str[i]);
             if(p->cnt==1)
                break; 
         }
         printf("\n");
    }     
    int main()
    {
        int n=0, i; 
        root=(struct node *)calloc(1, sizeof(node)); 
        while(scanf("%s", ch[n])!=EOF)
        {
            Maketree(ch[n]);
             n++;
        }
        for(i=0; i<n; i++)
        {
            printf("%s ", ch[i]); 
            Findtree(ch[i]);
        } 
    }     
  • 相关阅读:
    Delete 语句带有子查询的sql优化
    标量子查询SQL改写
    自定义函数导致的sql性能问题
    Oracle 11G RAC For ASM 利用RMAN COPY进行存储迁移
    WPF 如何控制右键菜单ContextMenu的弹出
    将字符串以用二进制流的形式读入XML文件
    WPF 将数据源绑定到TreeView控件出现界面卡死的情况
    WPF如何实现TreeView节点重命名
    Azure一个Cloud Service支持多个公网地址
    Azure上部署Barracuda WAF集群 --- 2
  • 原文地址:https://www.cnblogs.com/Hilda/p/2635842.html
Copyright © 2011-2022 走看看