zoukankan      html  css  js  c++  java
  • HDU 4004 The Frog's Games 【二分】

    Problem Description
    The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
    are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
     
    Input
    The input contains several cases. The first line of each case contains three positive integer L, n, and m.
    Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
     
    Output
    For each case, output a integer standing for the frog's ability at least they should have.
     
    Sample Input
    6 1 2 2 25 3 3 11 2 18
     
    Sample Output
    4 11
     
    题意:就是说青蛙想过一条河,河的宽度L ,有N块石头 ,青蛙最多可跳M次  ,求青蛙的最小弹跳能力
    思路:二分实现
    代码如下:
    View Code
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int f[500005], len, m, n;
    int judge(int mm)
    {
        int dis=0, count=1, i;
        if(f[0]-dis>mm)
            return 0;
        for(i=1; i<=n; i++)
        {
            if(f[i]-dis>mm)
            {
                dis=f[i-1];
                if(f[i]-dis>mm)
                    return 0;
                count++;
            }
        }
        if(count>m)
            return 0;
        return 1;
    }
    int main()
    {
        int i, j, mid, left, right;
        while(scanf("%d%d%d", &len, &n, &m)!=EOF)
        {
            f[0]=0;
            for(i=0; i<n; i++)
                scanf("%d", &f[i]);
            f[n]=len;
            sort(f, f+n+1);
            int dis=0;
            left=0, right=len;
            while(left<right)
            {
                //mid=(left+right)/2;
                mid=left+(right-left)/2;
                if(judge(mid)) //跳的步数小了
                    right=mid;
                else
                    left=mid+1;
            }
            printf("%d\n", right);
        }
    }
  • 相关阅读:
    查看PL/SQL编译时的错误信息
    Oracle字符集的查看查询和Oracle字符集的设置修改
    关于数字货币 韩国似乎在下一盘大棋
    上传图片如何对图片进行压缩canvas
    socket应用(vue、node.js、M站)
    web前端学习python之第一章_基础语法(二)
    从零开始 —— Canvas(一)
    前端必备之Node+mysql+ejs模版如何写接口
    浏览器缓存机制
    前端实现数组去重,如何高效快捷?
  • 原文地址:https://www.cnblogs.com/Hilda/p/2635905.html
Copyright © 2011-2022 走看看