zoukankan      html  css  js  c++  java
  • 1064.Complete Binary Search Tree [二叉搜索树的建立和层序遍历]

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    The left subtree of a node contains only nodes with keys less than the node’s key.
    The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
    Both the left and right subtrees must also be binary search trees.
    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:
    Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:
    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:
    10
    1 2 3 4 5 6 7 8 9 0
    
    Sample Output:
    6 3 8 1 5 7 9 0 2 4
    

    看了网上的做法,确实难想,利用二叉搜索树中序遍历是递增序列的性质,进行中序遍历的同时存进带有层序下标的数组中,最后将数组输出。
    要我想的话肯定是建树后再层序输出,原谅我太愚蠢,懒得打了
    https://blog.csdn.net/weixin_41144066/article/details/102591085 代码和和这个差不多~
    #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    vector<int>s1, s2; int n;
    void getlevel(int root)
    {	
    	s1.resize(n);
    	static int index = 0; //注意index要申明为全局变量
    	if (root >= n) return;
    	getlevel(root * 2 + 1);
    	s1[root] = s2[index++];
    	getlevel(root * 2 + 2);
    }
    int main()
    {
    	cin >> n; s2.resize(n);
    	for (int i = 0; i < n; i++)
    		cin >> s2[i];
    	sort(s2.begin(), s2.end());
    	getlevel(0);
    	cout << s1[0];
    	for (int i = 1; i < n; i++)
    		cout << " "<<s1[i];
    }
    
  • 相关阅读:
    影响cpu性能的因素有哪些?
    linux系统中 SElinux安全子系统
    linux 系统中个人用户主页功能
    理解 Segmentation fault
    VI高级命令集锦
    How to be a Star 怎样成为明星?
    名词解释:DEADBEEF
    Unix还能走多远?
    Awk 实例,第 1 部分
    77年出生的朋友,你们过的还好吗?
  • 原文地址:https://www.cnblogs.com/Hsiung123/p/13109981.html
Copyright © 2011-2022 走看看