zoukankan      html  css  js  c++  java
  • 1043.Is It a Binary Search Tree [二叉搜索树||二叉搜索树的前序转后序]

    1043 Is It a Binary Search Tree (25分)

    解题思路:这道题就是要联想一般的建树过程,一开始完全一脸懵,后面才慢慢懂了点,还要不断理解。注意那个放入动态数组中放在不同位置就是不同次序遍历的实现

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    The left subtree of a node contains only nodes with keys less than the node’s key.
    The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
    Both the left and right subtrees must also be binary search trees.
    If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

    Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input 1:
    7
    8 6 5 7 10 8 11
    
    Sample Output 1:
    YES
    5 7 6 8 11 10 8
    
    Sample Input 2:
    7
    8 10 11 8 6 7 5
    
    Sample Output 2:
    YES
    11 8 10 7 5 6 8
    
    Sample Input 3:
    7
    8 6 8 5 10 9 11
    
    Sample Output 3:
    NO
    

    #include<iostream>
    #include<vector>
    using namespace std;
    vector<int>pre, post;
    bool mirror = false;
    //二叉搜索树前序转后序(联想一般的建树过程)
    void getpost(int root, int ed)
    {
    	if (root > ed) return;
    	int i = root + 1, j = ed;
    	if (!mirror) {
    		while (i <= ed && pre[i] < pre[root]) i++;//右子树的根节点
    		while (j > root&& pre[j] >= pre[root]) j--;//左子树的最后一个节点
    	}
    	else {
    		while (i <= ed && pre[i] >= pre[root]) i++;//右子树的根节点
    		while (j > root&& pre[j] < pre[root]) j--;//左子树的最后一个节点
    	}
    	if (i - j != 1) return;
    	getpost(root + 1, j);
    	getpost(i, ed);
    	post.push_back(pre[root]);//后序放最后,中序就放中间。
    }
    int main()
    {
    	int n; cin >> n;
    	pre.resize(n);
    	for (int i = 0; i < n; i++)
    		cin >> pre[i];
    	getpost(0, n - 1);
    	if (post.size() != n) {
    		mirror = true;
    		post.clear();
    		getpost(0, n - 1);
    	}
    	if (post.size() != n) {
    		cout << "NO";
    	}
    	else {
    		int i = 0;
    		cout << "YES" << endl;
    		cout << post[i];
    		for(i=1;i<n;i++)
    		cout << " " << post[i];
    	}
    
    }
    
    
  • 相关阅读:
    【学习笔记】数据库设计那些事
    django rest-farme-work 的使用(3)
    django rest-farme-work 的使用(2)
    docker 的安装
    中国电信线CTF线下选拨writeup
    django rest-farme-work 的使用(1)
    谈谈python里面关于任务队列
    kubernetes 部署
    凯撒密码的加密解密
    Linux 密码的暴力破解
  • 原文地址:https://www.cnblogs.com/Hsiung123/p/13109982.html
Copyright © 2011-2022 走看看