zoukankan      html  css  js  c++  java
  • 10.排序5 PAT Judge [排序的灵活使用]

    这道题的意思就是,交了通过编译器的就显示出来,但是一道题都没有通过编译器的就凉凉,名字都没有,通过编译器但没成绩是0,没通过的是-1,然后就这样

    The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

    user_id problem_id partial_score_obtained

    where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, you are supposed to output the ranklist in the following format:

    rank user_id total_score s[1] … s[K]

    where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

    The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

    Sample Input:

    7 4 20
    20 25 25 30
    00002 2 12
    00007 4 17
    00005 1 19
    00007 2 25
    00005 1 20
    00002 2 2
    00005 1 15
    00001 1 18
    00004 3 25
    00002 2 25
    00005 3 22
    00006 4 -1
    00001 2 18
    00002 1 20
    00004 1 15
    00002 4 18
    00001 3 4
    00001 4 2
    00005 2 -1
    00004 2 0

    Sample Output:

    1 00002 63 20 25 - 18
    2 00005 42 20 0 22 -
    2 00007 42 - 25 - 17
    2 00001 42 18 18 4 2
    5 00004 40 15 0 25 -

    #include<iostream>
    #include<algorithm>
    #include<vector>
    using namespace std;
    struct student {
    	int id, rank, total = 0;
    	int solvenum = 0;
    	bool isshown = false;
    	vector<int>score;
    };
    bool cmp1(student a, student b) {
    	if (a.total != b.total)
    		return a.total > b.total;
    	else if (a.solvenum != b.solvenum)
    		return a.solvenum > b.solvenum;
    	else
    		return a.id < b.id;
    }
    int main()
    {
    	int n, k, m, id, num, score;
    	cin >> n >> k >> m;
    	vector<student>v(n + 1);
    	for (int i = 1; i <= n; i++)
    		v[i].score.resize(k + 1, -1);
    	vector<int>full(k + 1);
    	for (int i = 1; i <= k; i++)
    		cin >> full[i];
    	for (int i = 0; i < m; i++) {
    		cin >> id >> num >> score;
    		v[id].id = id;
    		v[id].score[num] = max(v[id].score[num], score);
    		if (score != -1)
    			v[id].isshown = true;
    		else if (v[id].score[num] == -1)
    			v[id].score[num] = -2;
    	}
    	for (int i = 1; i <= n; i++) {
    		for (int j = 1; j <= k; j++) {
    			if (v[i].score[j] != -1 && v[i].score[j] != -2)
    				v[i].total += v[i].score[j];
    			if (v[i].score[j] == full[j])
    				v[i].solvenum++;
    		}
    	}
    	sort(v.begin() + 1, v.end(), cmp1);
    	for (int i = 1; i <= n; i++) {
    		v[i].rank = i;
    		if (i != 1 && v[i].total == v[i - 1].total)
    			v[i].rank = v[i - 1].rank;
    	}
    	for (int i = 1; i <= n; i++) {
    		if (v[i].isshown == true) {
    			printf("%d %05d %d", v[i].rank, v[i].id, v[i].total);
    			for (int j = 1; j <= k; j++) {
    				if (v[i].score[j] != -1 && v[i].score[j] != -2)
    					cout << " " << v[i].score[j];
    				else if (v[i].score[j] == -1)
    					cout << " -";
    				else 
    					cout << " 0";
    			}
    			cout << endl;
    		}
    	}
    	return 0;
    }
    
  • 相关阅读:
    java基础之switch
    String的getBytes()方法
    Android adb命令
    shell中grep命令详解
    su root 和su
    adb shell 命令详解
    adb shell am 的用法
    adb logcat 基本用法
    Android、iOS和Windows Phone中的推送技术
    Android客户端消息推送原理简介
  • 原文地址:https://www.cnblogs.com/Hsiung123/p/13109990.html
Copyright © 2011-2022 走看看