zoukankan      html  css  js  c++  java
  • A1035 Password [修改字符]

    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line “There are N accounts and no account is modified” where N is the total number of accounts. However, if N is one, you must print “There is 1 account and no account is modified” instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    Sample Output 1:
    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    Sample Input 2:
    1
    team110 abcdefg332
    Sample Output 2:
    There is 1 account and no account is modified
    Sample Input 3:
    2
    team110 abcdefg222
    team220 abcdefg333
    Sample Output 3:
    There are 2 accounts and no account is modified

    题目大意:给定n个用户的姓名和密码,把密码中的1改为@,0改为%,l改为L,O改为o
    如果不存在需要修改的密码,则输出There are n accounts and no account is modified。注意单复数,如果只有一个账户,就输出There is 1 account and no account is modified

    #include<iostream>
    #include<cstring>
    using namespace std;
    struct node {
    	char name[20], password[20];
    	bool ischange;
    }a[1005];
    void xiugai(node& a, int& cnt)
    {
    	int length = strlen(a.password);
    	for (int j = 0; j < length; j++)
    	{
    		if (a.password[j] == 'l' || a.password[j] == '1' || a.password[j] == '0' || a.password[j] == 'O')
    		{
    			if (a.password[j] == 'l')
    				a.password[j] = 'L';
    			else if (a.password[j] == '1')
    				a.password[j] = '@';
    			else if (a.password[j] == '0')
    				a.password[j] = '%';
    			else if (a.password[j] == 'O')
    				a.password[j] = 'o';
    			a.ischange = 1;
    		}
    	}
    	if (a.ischange)
    		cnt++;
    }
    int main()
    {
    	int n; cin >> n; int cnt = 0;
    	for (int i = 0; i < n; i++)
    	{
    		cin >> a[i].name >> a[i].password;
    		a[i].ischange = 0;
    	}
    	for (int i = 0; i < n; i++)
    	{
    		xiugai(a[i], cnt);
    	}
    	if (cnt == 0)
    	{
    		if (n == 1)
    		{
    			cout << "There is 1 account and no account is modified" << endl;
    		}
    		else
    		{
    			cout << "There are " << n << " accounts and no account is modified" << endl;
    		}
    	}
    	else {
    		cout << cnt << endl;
    		for (int i = 0; i < n; i++)
    		{
    			if (a[i].ischange)
    				cout << a[i].name << " " << a[i].password << endl;
    		}
    	}
    	
    }
    
  • 相关阅读:
    002-数据库命名开发规范
    006-多线程-基础-同步解决 概述【ReentrantLock、Semaphore、CyclicBarrier、CountDownLatch】
    005-多线程-基础-sleep、join、yield、wait、notify、notifyAll、run、start、synchronized
    004-多线程-基础-同步问题引出、同步问题解决、死锁、生产者与消费者
    003-多线程-基础-其他【命名和取得、休眠、优先级、线程状态、线程中断】
    002-多线程-基础-实现方式【thread、runnable、callale、thread和runnable对比】
    001-多线程-基础-进程线程、线程状态、优先级、用户线程和守护线程
    001-Spring在代码中获取bean的几种方式
    004-mysql explain详解
    java-序列化-001-原生介绍
  • 原文地址:https://www.cnblogs.com/Hsiung123/p/13812088.html
Copyright © 2011-2022 走看看