zoukankan      html  css  js  c++  java
  • AC日记——【模板】字符串哈希 洛谷 3370

    题目描述

    如题,给定N个字符串(第i个字符串长度为Mi,字符串内包含数字、大小写字母,大小写敏感),请求出N个字符串中共有多少个不同的字符串。

    友情提醒:如果真的想好好练习哈希的话,请自觉,否则请右转PJ试炼场:)

    输入输出格式

    输入格式:

    第一行包含一个整数N,为字符串的个数。

    接下来N行每行包含一个字符串,为所提供的字符串。

    输出格式:

    输出包含一行,包含一个整数,为不同的字符串个数。

    输入输出样例

    输入样例#1:
    5
    abc
    aaaa
    abc
    abcc
    12345
    输出样例#1:
    4

    说明

    时空限制:1000ms,128M

    数据规模:

    对于30%的数据:N<=10,Mi≈6,Mmax<=15;

    对于70%的数据:N<=1000,Mi≈100,Mmax<=150

    对于100%的数据:N<=10000,Mi≈1000,Mmax<=1500

    样例说明:

    样例中第一个字符串(abc)和第三个字符串(abc)是一样的,所以所提供字符串的集合为{aaaa,abc,abcc,12345},故共计4个不同的字符串。

    Tip: 感兴趣的话,你们可以先看一看以下三题:

    BZOJ3097:http://www.lydsy.com/JudgeOnline/problem.php?id=3097

    BZOJ3098:http://www.lydsy.com/JudgeOnline/problem.php?id=3098

    BZOJ3099:http://www.lydsy.com/JudgeOnline/problem.php?id=3099

    如果你仔细研究过了(或者至少仔细看过AC人数的话),我想你一定会明白字符串哈希的正确姿势的^_^

    思路:

      hash!!!

      链表hash

      把每个字符串处理成两个hash值

      然后第一个哈希值作为链表存储的根

      另外一个作为链表存储的值

      然后

      每次判断是否存在这个hash值

      如果不存在就加入这个hash值而且ans++

      最后输出ans

      轻松ac

    来,上代码:

    #include <queue>
    #include <cstdio>
    #include <cstring>
    #include <iostream>
    #include <algorithm>
    
    #define mod 999997
    #define mod_ 99999997
    
    using namespace std;
    
    struct node {
        int hash;
        struct node* next;
    };
    struct node num[1000100];
    struct node* head[10000010];
    
    int n,len,hash,ans=0,num_=0;
    
    long long int hash_;
    
    char Cgets[1501000];
    
    inline void do_(int to,long long int dis)
    {
        struct node* next=head[to];
        while(next!=NULL)
        {
            if(next->hash==dis) return ;
            next=next->next;
        }
        num[++num_].hash=dis;
        num[num_].next=head[to];
        head[to]=&num[num_];
        ans++;
    }
    
    int main()
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            cin>>Cgets;
            len=strlen(Cgets);
            hash=1,hash_=1;
            for(int j=0;j<len;j++)
            {
                if(j%2) hash_=(hash_*Cgets[j]*17)%mod_;
                hash=(hash*Cgets[j]*19)%mod;
            }
            do_(hash,hash_);
        }
        cout<<ans<<endl;
        return 0;
    }
  • 相关阅读:
    MySQL explain,Extra分析(转)
    MySQL explain,type分析(转)
    HTTP报文结构和内容(转)
    linux 环境 Xshell操作数据库
    服务器线上问题排查研究
    服务性能指标:PV、UV、TPS、QPS
    Git推送错误Remote: User permission denied错误解决方法
    SQL Server表关联
    SQL Server执行计划
    C#正则Groups高级使用方法
  • 原文地址:https://www.cnblogs.com/IUUUUUUUskyyy/p/6286008.html
Copyright © 2011-2022 走看看