zoukankan      html  css  js  c++  java
  • HDOJ 4006 The kth great number

    这道题来自于 The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest

    线段树求第 k 大值,包含修改和询问;

    ----------------------------------------------------------------------------

    Problem Description

    Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
     

    Input

    There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
     

    Output

    The output consists of one integer representing the largest number of islands that all lie on one line.
     

    Sample Input

    8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
     

    Sample Output

    1 2 3

    -----------------------------------------------------------------------------

    # include <stdio.h>
    # include <string.h>
    
    # define N 1000005
    
    int n, k, D;
    int cnt[4 * N];
    
    void update(int i)
    {
        for (i += D; i ^ 1; i >>= 1)
        {
            cnt[i >> 1] = cnt[i] + cnt[i ^ 1];
        }
    }
    
    int query(int p)
    {
        int i;
        
        for (i = 1; i < D; )
        {
            i = i << 1 | 1;
            if (p > cnt[i]) p -= cnt[i], i = i ^ 1;
        }
        
        return i - D;
    }
    
    void init(void)
    {
        int i;
    
        for (D = 1; D < N; D <<= 1) ;
        for (i = 0; i < 2*D+2; ++i)
            cnt[i] = 0;
    }
    
    void solve(void)
    {
        int i, val;
        char s[5];
    
        for (i = 1; i <= n; ++i)
        {
            scanf("%s", s);
            switch(s[0])
            {
            case 'I': {scanf("%d", &val); ++cnt[val+D]; update(val); break;}
            case 'Q': {printf("%d\n", query(k)); break;}
            }
        }
    }
    
    int main()
    {
        while (~scanf("%d%d", &n, &k))
        {
            init();
            solve();
        }
    
        return 0;
    }

    -----------------------------------------------------------------------------

  • 相关阅读:
    原生CSS、HTML 和 JavaScript 实现酷炫表单
    Vite2 如何设置打包后文件名
    读罢effective java,并不感觉特别好
    第六章部分习题答案
    第七章部分习题答案
    第八章部分习题答案
    mybatis 3.3.0之前版本的一个空指针BUG
    避免使用finalize方法
    mlp房价预测
    逻辑回归
  • 原文地址:https://www.cnblogs.com/JMDWQ/p/2586566.html
Copyright © 2011-2022 走看看