zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1083 List Grades (25分) (思路转换)

    1.题目

    Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

    Input Specification:

    Each input file contains one test case. Each case is given in the following format:

    N
    name[1] ID[1] grade[1]
    name[2] ID[2] grade[2]
    ... ...
    name[N] ID[N] grade[N]
    grade1 grade2
    

    where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case you should output the student records of which the grades are in the given interval [grade1grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

    Sample Input 1:

    4
    Tom CS000001 59
    Joe Math990112 89
    Mike CS991301 100
    Mary EE990830 95
    60 100
    

    Sample Output 1:

    Mike CS991301
    Mary EE990830
    Joe Math990112
    

    Sample Input 2:

    2
    Jean AA980920 60
    Ann CS01 80
    90 95
    

    Sample Output 2:

    NONE
    

    2.题目分析

    开始的思路是使用vector存放struct,然后针对grade进行排序,但是当我看到grade1,grade2最后才给出,有猫腻可能!

    而且N的范围也没给,但是给了grade的范围,于是不排序,直接将grade为X(1<=X<=100)的记录插入vector<node>out[101];第X行,倒着输出就行

    3.代码

    #include<iostream>
    #include<vector>
    #include<string>
    #include<cstring>
    using namespace std;
    struct node
    {
    	string name;
    	string id;
    };
    int main()
    {
    	int n,grade,grade1,grade2;
    	bool none = true;
    	string name,id;
    	scanf("%d", &n);
    	vector<node>out[101];
    	for (int i = 0; i < n; i++)
    	{
    		cin >> name >> id >> grade;
    		out[grade].push_back({ name,id });
    	}
    	cin >> grade1 >> grade2;
    	for (int i = grade2; i >= grade1; i--)
    	{
    		for (int j = 0; j < out[i].size(); j++)
    		{
    			cout << out[i][j].name << " " << out[i][j].id << endl; none = false;
    		}
    	}
    	if (none)cout << "NONE" << endl;
    }
  • 相关阅读:
    echarts二维坐标这样写出立体柱状图
    echarts中使图表循环显示tooltip-封装tooltip的方法轮询显示图表数据
    webpack--运行npm run dev自动打开浏览器以及热加载
    exports、module.exports和export、export default到底是咋回事,区别在哪里
    H5页面判断客户端是iOS或是Android并跳转对应链接唤起APP
    关于页面锚点跳转以及万能锚点跳转插件
    echarts Map 省份文字居中,即对应地图中心位置
    Moment.js 常见用法,常见API
    Tomcat 不加载图片验证码
    Cglib 动态代理
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788827.html
Copyright © 2011-2022 走看看