zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1089 Insert or Merge (25分)

    1.题目

    According to Wikipedia:

    Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

    Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

    Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input 1:

    10
    3 1 2 8 7 5 9 4 6 0
    1 2 3 7 8 5 9 4 6 0
    

    Sample Output 1:

    Insertion Sort
    1 2 3 5 7 8 9 4 6 0
    

    Sample Input 2:

    10
    3 1 2 8 7 5 9 4 0 6
    1 3 2 8 5 7 4 9 0 6
    

    Sample Output 2:

    Merge Sort
    1 2 3 8 4 5 7 9 0 6

    2.题目分析

    PAT (Basic Level) Practice 1035 插入与归并 (25分) (归并排序)

    3.代码

    #include<iostream>
    #include<algorithm>
    #include<cmath>
    using namespace std;
    int a[101],b[101],temp[101];
    int main()
    {
    	int n;
    	cin >> n;
    	for (int i = 0; i < n; i++)
    	{
    		cin >> a[i];
    		b[i] = a[i];
    	}
    	for (int i = 0; i < n; i++)
    		cin >> temp[i];
    	int count = 0;
    	bool isa = false;
    	int i = 0;
    	//寻找
    	for ( i = 2; i <=n; i++)
    	{
    		count = 0;
    		sort(a, a + i);
    		if (isa == true)break;
    		for (int j = 0; j < n; j++)
    		{
    			if (a[j] == temp[j])
    				count++;
    			if (count == n) { isa = true; break; }
    		}
    	}
    	//输出
    	if (isa == true)
    	{
    		cout << "Insertion Sort" << endl;
    		int space = 0;
    		for (int j = 0; j < n; j++)
    		{			
    				if (space == 0) { cout << a[j]; space++; }
    				else
    					cout << ' ' << a[j];	
    		}
    	}
    	bool isb = false;
    	for ( i = 2;; i *= 2) //归并排序从两个两个开始,最后不够两个就截止n就行
    	{   
    		for (int j = 0; j < n; j += i) 
    		{
    			sort(b + j, b + (j + i < n ? j + i : n)); 
    		}
    		if (isb) 
    		{
    			cout << "Merge Sort" << endl;
    			cout << b[0];
    			for (int j = 1; j < n; j++)
    				cout << " " << b[j];
    			return 0;
    		}
    		if (equal(b, b + n, temp))
    			isb=true;
    		if (i > n)
    			break;
    	}
    }
  • 相关阅读:
    线程池中的scheduleAtFixedRate scheduleWithFixedDelay区别
    几道MySQL问题
    【SQL server 2012】复制数据库到另一台机器上
    LeetCode 98. 验证二叉搜索树
    深度学习知识点
    Graph Network Notes
    剑指 Offer 33. 二叉搜索树的后序遍历序列
    剑指 Offer 29. 顺时针打印矩阵
    LeetCode 54. 螺旋矩阵
    LeetCode 50. Pow(x, n)
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788834.html
Copyright © 2011-2022 走看看