zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1092 To Buy or Not to Buy (20分)

    1.题目

    Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

    For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

    figbuy.jpg

    Figure 1

    Input Specification:

    Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

    Output Specification:

    For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

    Sample Input 1:

    ppRYYGrrYBR2258
    YrR8RrY
    

    Sample Output 1:

    Yes 8
    

    Sample Input 2:

    ppRYYGrrYB225
    YrR8RrY
    

    Sample Output 2:

    No 2

     2.题目分析

    PAT (Basic Level) Practice 1039 到底买不买 (20分) (string 的find函数、erase函数)

     3.代码

    #include<iostream>
    #include<string>
    #include<cstring>
    using namespace std;
    int main()
    {
        string sell,buy;
        cin>>sell;
        cin>>buy;
        int salelength=sell.length();
        int lack=0;
        for(int i=0;i<buy.length();i++)
            if(sell.find(buy[i])!=string::npos)sell.erase(sell.find_first_of(buy[i]),1);
            else lack++;
        if(lack==0)cout<<"Yes "<<salelength-buy.length();
        else cout<<"No "<<lack;
    }
  • 相关阅读:
    jetcache 二级缓存使用
    hutool-crypto 依赖 Aes加密,解密
    springboot下的logback-spring配置文件以及使用方式
    docker 实现多个端口映射
    zookeeper部署启动异常,8080端口被占用。
    docker tomcat 文件传递
    关于注解AOP,基于类和方法的实现
    idea 创建file找不到java文件时....
    idea 将项目代码提交到github中
    java第八天---多态、抽象、接口
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788839.html
Copyright © 2011-2022 走看看