zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1101 Quick Sort (25分)

    1.题目

    There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

    For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

    • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
    • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
    • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
    • and for the similar reason, 4 and 5 could also be the pivot.

    Hence in total there are 3 pivot candidates.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

    Output Specification:

    For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

    Sample Input:

    5
    1 3 2 4 5
    

    Sample Output:

    3
    1 4 5

    2.代码

    
    
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int list[100001], output[100001] = { 0 };
    int main()
    {
    	int n;
    	cin >> n;
    	int max = -1, min = 1000000009;
    	int count = 0;
    	for (int i = 0; i < n; i++)
    		scanf("%d", &list[i]);
    	for (int i = 0; i < n; i++)
    	{
    
    		if (max < list[i]) { output[i]++; max = list[i]; }
    	}
    	for (int i = n - 1; i >= 0; i--)
    	{
    		if (min > list[i]) { output[i]++; min = list[i]; }
    	}
    	for (int i = 0; i < n; i++)
    		if (output[i] == 2)count++;
    	cout << count << endl;
    
    	int space = 0;
    	for (int i = 0; i<n; i++)
    	{
    		if (output[i] == 2)
    		{
    			if (space == 0) { cout << list[i]; space++; }
    			else cout << ' ' << list[i];
    		}
    	}
    	cout << endl;
    
    }
  • 相关阅读:
    delphi 指针 认识
    delphi Post数据到网页
    delphi将图片转换成Base64编码函数
    delphi 获取windows任务栏的高度
    获取当天是星期几,计算两个日期相隔时间
    博客园样式自定义(待更新)
    redux超易学三篇之三(一个逻辑完整的react-redux)
    redux超易学三篇之二(开始使用react-redux)
    redux超易学三篇之一(单独说redux)
    毕业季
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788845.html
Copyright © 2011-2022 走看看