zoukankan      html  css  js  c++  java
  • PAT (Advanced Level) Practice 1152 Google Recruitment (20分)

    1.题目

    In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

    prime.jpg

    The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

    Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

    Input Specification:

    Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

    Output Specification:

    For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

    Sample Input 1:

    20 5
    23654987725541023819
    

    Sample Output 1:

    49877
    

    Sample Input 2:

    10 3
    2468024680
    

    Sample Output 2:

    404

    2.代码

    #include<iostream>
    #include<string>
    #include<cstring>
    #include<cmath>
    using namespace std;
    bool isprime(int num)
    {
    	if (num == 0 || num == 1)return false;
    	for (int i = 2; i <= sqrt(num); i++)
    	{
    		if (num%i == 0)return false;
    	}
        return true;
    }
    int main()
    {
    	int l, k;
    	cin >> l >> k;
    	string list;
    	cin >> list;
    	for (int i = 0; i <= l - k; i++)
    	{
    		if (isprime(atoi(list.substr(i, k).c_str())))
    		{
    			cout << list.substr(i, k); return 0;
    		}
    	}
    	cout << 404;
        return 0;
    }
    
  • 相关阅读:
    HTML5 实现Link跳线效果
    在TWaver的Tree节点上画线
    用TWaver加载大型游戏场景一例
    22万个木箱!TWaver 3D极限压榨
    如何在MONO 3D寻找最短路路径
    如何创建TWaver 3D的轮廓选中效果
    巧用TWaver 3D 矢量图形功能
    如何实现TWaver 3D颜色渐变
    HDU 1390 Binary Numbers
    HDU 1328 IBM Minus One
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788884.html
Copyright © 2011-2022 走看看