zoukankan      html  css  js  c++  java
  • PAT (Basic Level) Practice 1052 卖个萌 (20分) (注意转义符!!!)

    1.题目

    萌萌哒表情符号通常由“手”、“眼”、“口”三个主要部分组成。简单起见,我们假设一个表情符号是按下列格式输出的:

    [左手]([左眼][口][右眼])[右手]
    

    现给出可选用的符号集合,请你按用户的要求输出表情。

    输入格式:

    输入首先在前三行顺序对应给出手、眼、口的可选符号集。每个符号括在一对方括号 []内。题目保证每个集合都至少有一个符号,并不超过 10 个符号;每个符号包含 1 到 4 个非空字符。

    之后一行给出一个正整数 K,为用户请求的个数。随后 K 行,每行给出一个用户的符号选择,顺序为左手、左眼、口、右眼、右手——这里只给出符号在相应集合中的序号(从 1 开始),数字间以空格分隔。

    输出格式:

    对每个用户请求,在一行中输出生成的表情。若用户选择的序号不存在,则输出 Are you kidding me? @/@

    输入样例:

    [╮][╭][o][~][/~]  [<][>]
     [╯][╰][^][-][=][>][<][@][⊙]
    [Д][▽][_][ε][^]  ...
    4
    1 1 2 2 2
    6 8 1 5 5
    3 3 4 3 3
    2 10 3 9 3
    

    输出样例:

    ╮(╯▽╰)╭
    <(@Д=)/~
    o(^ε^)o
    Are you kidding me? @/@

    2.题目分析

    注意输出要加上转义符!!

    用户输入的数字可能为0、负数

    3.代码

    #include<iostream>
    #include<cstdio>
    #include<string>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    string hand, eye, mouth;
    int handcount=1, eyecount=1, mouthcount=1;
    string handlist[11], eyelist[11],mouthlist[11];
    void process(string list[],string &str,int &count)
    {
    	while (1)
    	{
    		if (str.find('[') == string::npos)break;
    		list[count++] = str.substr(str.find_first_of('[')+1 , str.find_first_of(']')- str.find_first_of('[')-1);
    		str.erase(str.find_first_of('['), 1); str.erase(str.find_first_of(']'), 1);
    	}
    }
    int main()
    {
    	getline(cin, hand);
    	getline(cin, eye);
    	getline(cin, mouth);
    	process(handlist,hand, handcount);
    	process(eyelist,eye, eyecount);
    	process(mouthlist,mouth, mouthcount);
    	int n;
    	cin >> n;
    	int a, b, c, d, e;
    	for (int i = 0; i < n; i++)
    	{
    		cin >> a >> b >> c >> d >> e;
    		if (a > handcount-1 || e > handcount-1|| b > eyecount-1 || d > eyecount-1||c>mouthcount-1 || a<1||b<1||c<1||d<1||e<1)
    		{ cout << "Are you kidding me? @\/@" << endl; continue; }
    		cout << handlist[a] <<'('<< eyelist[b] << mouthlist[c] << eyelist[d] <<')'<< handlist[e] << endl;
    	}
    
    }
  • 相关阅读:
    接口测试基础知识
    WebSocket接口怎么做测试
    python的数据类型特点和常用方法
    python封装一个工具类 ,对MySQL数据库增删改查
    python 往MySQL批量插入数据
    python对MySQL进行曾删改查
    Rest Assured从入门到遇到各种问题(汇总、更新)
    jmeter参数化之动态读取csv文件
    Charles 浏览器(火狐)抓包设置
    导入git项目报错"no projects are found to import" 找不到项目
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12788939.html
Copyright © 2011-2022 走看看