zoukankan      html  css  js  c++  java
  • 数据结构与算法题目集(中文)7-3 树的同构 (25分)

    1.题目

    给定两棵树T1和T2。如果T1可以通过若干次左右孩子互换就变成T2,则我们称两棵树是“同构”的。例如图1给出的两棵树就是同构的,因为我们把其中一棵树的结点A、B、G的左右孩子互换后,就得到另外一棵树。而图2就不是同构的。

    图1

    图2

    现给定两棵树,请你判断它们是否是同构的。

    输入格式:

    输入给出2棵二叉树树的信息。对于每棵树,首先在一行中给出一个非负整数N (≤10),即该树的结点数(此时假设结点从0到N−1编号);随后N行,第i行对应编号第i个结点,给出该结点中存储的1个英文大写字母、其左孩子结点的编号、右孩子结点的编号。如果孩子结点为空,则在相应位置上给出“-”。给出的数据间用一个空格分隔。注意:题目保证每个结点中存储的字母是不同的。

    输出格式:

    如果两棵树是同构的,输出“Yes”,否则输出“No”。

    输入样例1(对应图1):

    8
    A 1 2
    B 3 4
    C 5 -
    D - -
    E 6 -
    G 7 -
    F - -
    H - -
    8
    G - 4
    B 7 6
    F - -
    A 5 1
    H - -
    C 0 -
    D - -
    E 2 -
    

    输出样例1:

    Yes
    

    输入样例2(对应图2):

    8
    B 5 7
    F - -
    A 0 3
    C 6 -
    H - -
    D - -
    G 4 -
    E 1 -
    8
    D 6 -
    B 5 -
    E - -
    H - -
    C 0 2
    G - 3
    F - -
    A 1 4
    

    输出样例2:

    No

    2.代码

    #include<iostream>
    using namespace std;
    typedef struct TNode Tree;
    struct TNode 
    {
    	char data;
    	int left;
    	int right;
    
    }l[101],r[101];
    int list[101] = {0};
    
    int buildtree(Tree tree[])
    {
    
    	int n;
    	cin >> n;
    	if (n == 0)return -1;
    	for (int i = 0; i < n; i++)
    		list[i] = 0;
    	char a, b, c;
    	for (int i = 0; i < n; i++)
    	{
    		cin >> a >> b >> c;
    		tree[i].data = a;
    		if (b != '-')
    		{
    			tree[i].left = b - '0';
    			list[tree[i].left] = 1;
    		}
    		else
    		{
    			tree[i].left = -1;
    		}
    		if (c != '-')
    		{
    			tree[i].right = c - '0';
    			list[tree[i].right] = 1;
    		}
    		else
    		{
    			tree[i].right = -1;
    		}
    	}
    	int root = 0;
    	for (int i = 0; i < n; i++)
    	{
    		if (list[i] == 0)
    			 root = i;
    	}
    	return root;
    }
    
    bool judge(int leftroot, int rightroot)
    {
    	if (leftroot == -1 && rightroot == -1)//两颗树都为空的情况
    		return true;
    	else if (leftroot == -1 && rightroot != -1 || leftroot != -1 && rightroot == -1)//其中一颗树为空的情况
    		return false;
    	else if (l[leftroot].data != r[rightroot].data)//两个树的根节点就不一样
    		return false;
    	else if (l[leftroot].left == -1 && r[rightroot].left == -1)//两个树都没有左节点
    		return judge(l[leftroot].right, r[rightroot].right);
    
    	else if (l[leftroot].left != -1 && r[rightroot].left != -1 && l[l[leftroot].left].data == r[r[rightroot].left].data)
    		return judge(l[leftroot].left, r[rightroot].left) && judge(l[leftroot].right, r[rightroot].right);
    	else
    		return judge(l[leftroot].left, r[rightroot].right) && judge(l[leftroot].right, r[rightroot].left);
    
    }
    int main()
    {
    	int leftroot = buildtree(l);
    	int rightroot = buildtree(r);
    	if (judge(leftroot, rightroot) == true)
    		cout << "Yes";
    	else
    		cout << "No";
    
    
    
    
    }
  • 相关阅读:
    Vue 兄弟组件通信(不使用Vuex)
    vue2.0 #$emit,$on的使用
    Bootstrap栅格系统基本使用
    字体图标使用
    js事件委托
    帆布小球碰壁效果
    vuex -- vue的状态管理模式
    JavaScript --经典问题
    总结获取原生JS(javascript)基本操作
    git的基本操作
  • 原文地址:https://www.cnblogs.com/Jason66661010/p/12789032.html
Copyright © 2011-2022 走看看