zoukankan      html  css  js  c++  java
  • [SOJ] Ordering Tasks

    1940. Ordering Tasks

    Constraints

    Time Limit: 1 secs, Memory Limit: 32 MB

    Description

     John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

    Input

    There are multiple test cases. The first line contains an integer T, indicating the number of test cases. Each test case begins with a line containing two integers, 1 <= n <= 100000 and 1 <= m <= 100000. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. It is guaranteed that no task needs to be executed before itself either directly or indirectly. 

    Output

    For each test case, print a line with n integers representing the tasks in a possible order of execution. To separate them, print exactly one space after each integer. If there are multiple solutions, output the smallest one by lexical order.  

    Sample Input

    1
    5 5
    3 4
    4 1
    3 2
    2 4
    5 3 

    Sample Output

    5 3 2 4 1  
     
    拓扑排序
    //AOV拓扑排序
    #include <iostream>
    #include <vector>
    #include <queue>
    #include <memory.h>
    using namespace std;
     
    int main() 
    {
      int numTestcases;
      cin >> numTestcases;
      
      while(numTestcases--)
      {
        int n, m;
        cin >> n >> m;
        int inDegree[n + 1];  //入度为0数组
        int result[n];        //结果序列
        vector<int> tasks[n + 1];   //每一组vector都有该结点的后继结点
        memset(inDegree, 0, sizeof(inDegree));  //初始化
        
        for (int i = 0; i < m; ++i)
        {
            int a, b;
            cin >> a >> b;
            inDegree[b]++;
            tasks[a].push_back(b);
        }
        
        priority_queue<int, vector<int>, greater<int> > readyTasks;//使用最小优先队列可以自动按照从小到大排序
        
        for (int i = 1; i <= n; ++i) 
        {//先将所有根结点放进队列中待选
            if(inDegree[i] == 0)
                readyTasks.push(i);
        }
    
        int numFinished = 0;
        
        while(!readyTasks.empty())
        {
            int cur = readyTasks.top();
            result[numFinished++] = cur;
            readyTasks.pop();
            vector<int>::iterator it;
            
            for(it = tasks[cur].begin(); it != tasks[cur].end();it++)
            {
                int temp = *it;
                inDegree[temp]--;
                if(inDegree[temp] == 0)//当前趋结点全部完成时可以开始这个任务
                    readyTasks.push(temp);
            }
        }
        
        for (int i = 0; i < n; ++i) 
        {
            cout << result[i] << " ";
        }
        cout << endl;
      }
      return 0;
    }
    

      

  • 相关阅读:
    基于NFS的PV动态供给(StorageClass)
    Helm学习笔记
    k8s日志收集方案
    okhttputils【 Android 一个改善的okHttp封装库】使用(三)
    PopupWindowMenuUtil【popupwindow样式菜单项列表】
    NewBuiltBottomSheetDialog【新建底部对话框】
    NormalDialogFragmentDemo【普通页面的DialogFragment】
    ArticleRemoveDelDialog【基于AlertDialog的回收删除对话框】
    ConfirmCancelBottomSheetDialog【确认取消底部对话框】
    Android-PickerView【仿iOS的PickerView控件,并封装了时间选择和选项选择这两种选择器】使用
  • 原文地址:https://www.cnblogs.com/KennyRom/p/6246600.html
Copyright © 2011-2022 走看看