zoukankan      html  css  js  c++  java
  • [POJ] Financial Management

    Financial Management
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 182193   Accepted: 68783

    Description

    Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

    Input

    The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

    Output

    The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

    Sample Input

    100.00
    489.12
    12454.12
    1234.10
    823.05
    109.20
    5.27
    1542.25
    839.18
    83.99
    1295.01
    1.75

    Sample Output

    $1581.42

    水炸的题
    #include<iostream>
    #include<iomanip>
    using namespace std;
    
    int main()
    {
    	double sum=0;
    	double money;
    
    	for(int i=0;i<12;i++)
    	{
    		cin>>money;
    		sum+=money;
    	}
    
    	sum/=12;
    
    	cout<<"$"<<fixed<<setprecision(2)<<sum<<endl;
    
    	return 0;
    }
    

      

  • 相关阅读:
    粘性固定 position:sticky
    vue组件样式scoped
    vue组件结构
    vue根据路由判断所在的内容
    配置系统变量
    div中放入一个img元素导致div高度会多出几个像素
    button标签设置line-height问题
    Netty学习——protoc的新手使用流程
    Netty学习——Google Protobuf的初步了解
    Netty学习——Google Protobuf使用方式分析和环境搭建
  • 原文地址:https://www.cnblogs.com/KennyRom/p/6511597.html
Copyright © 2011-2022 走看看