zoukankan      html  css  js  c++  java
  • POJ 3687 Labeling Balls(拓扑排序)题解

    Description

    Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

    1. No two balls share the same label.
    2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

    Can you help windy to find a solution?

    Input

    The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

    Output

    For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

    Sample Input

    5
    
    4 0
    
    4 1
    1 1
    
    4 2
    1 2
    2 1
    
    4 1
    2 1
    
    4 1
    3 2
    

    Sample Output

    1 2 3 4
    -1
    -1
    2 1 3 4
    1 3 2 4

    题意和思路:给你标号为1~N的球,a b代表a比b轻,需要你排列出这N个球的顺序,要求按编号字典序排列,最后要你依次给出这N个球的重量(这里要注意不是叫你给出编号的顺序,而是1的质量,2的质量...N的质量这样输出,就这里这WA了...)。思路很简单,就是把轻的球加度,然后重的指向轻的,然后度0的就是重的,优先队列要用降序,这样就能保证度为0的比较重的先取出,(这里用倒着存到ans[ ],从头往后读就是编号的正确顺序),但我们要注意他要我们输出重量,所以ans[ ]编号里从最后一个开始依次赋值1~N

    代码:

    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<cctype>
    #include<queue>
    #include<cmath>
    #include<string>
    #include<stack> 
    #include<set>
    #include<map>
    #include<vector>
    #include<iostream>
    #include<algorithm>
    #include<sstream>
    #define ll long long 
    const int N=210;
    const int INF=1e9;
    using namespace std;
    int n,m,degree[N],ans[N],weight[N];    //ans记录倒序的编号,weight记录最终答案
    vector<int> g[N];     //邻接表
    void topo(){
    	int cnt=0;
    	priority_queue<int,vector<int>,less<int> > q;
    	for(int i=1;i<=n;i++){
    		if(degree[i]==0) q.push(i);
    	}
    	while(!q.empty()){
    		int v=q.top();
    		q.pop();
    		ans[cnt]=v;
    		cnt++;
    		for(int i=0;i<g[v].size();i++){
    			int p=g[v][i];
    			degree[p]--;
    			if(degree[p]==0) q.push(p);
    		}
    	}
    	if(cnt!=n) cout<<-1<<endl;
    	else{
    		int wei=1;
    		for(int i=cnt-1;i>=0;i--){
    			weight[ans[i]]=wei++;
    		}
    		for(int i=1;i<=n;i++) printf("%d ",weight[i]); 
    		cout<<endl;
    	}
    }
    int main(){
    	int T,a,b;
    	scanf("%d",&T);
    	while(T--){
    		memset(degree,0,sizeof(degree));
    		for(int i=0;i<N;i++) g[i].clear();
    		scanf("%d%d",&n,&m);
    		for(int i=0;i<m;i++){
    			scanf("%d%d",&a,&b);
    			degree[a]++;	//轻的加度 
    			g[b].push_back(a);	
    		}
    		topo();
    	}
        return 0;  
    }  

  • 相关阅读:
    leetcode 之Search in Rotated Sorted Array(三)
    leetcode 之Remove Duplicates from Sorted Array(2)
    leetcode 之Remove Duplicates from Sorted Array(1)
    ImageNet Classification with Deep Convolutional Neural Network(转)
    Gradient-Based Learning Applied to Document Recognition 部分阅读
    C++面试总结
    Effective C++笔记(六):继承与面向对象设计
    Effective C++笔记(五):实现
    Effective C++笔记(四):设计与声明
    Learning a Deep Compact Image Representation for Visual Tracking
  • 原文地址:https://www.cnblogs.com/KirinSB/p/9409098.html
Copyright © 2011-2022 走看看