zoukankan      html  css  js  c++  java
  • C++求解最大子序列和、位置问题

    Maximum Subsequence Sum 

    Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:
    10
    -10 1 2 3 4 -5 -23 3 7 -21
    
    Sample Output:
    10 1 4

    ??????为什么测试是部分正确

    // MaxSubSet.cpp : Defines the entry point for the console application.
    //
    #include "stdafx.h"
    #include "stdio.h"
    #include "stdlib.h"
    #include <iostream>
    //using namespace std;
    void MaxSubsequenceSum(int a[],int n);
    int _tmain(int argc, _TCHAR* argv[])
    {
    int n = 0;
    scanf("%d",&n);
    int *a = new int[n];
    for(int i = 0;i<n;i++)
    scanf("%d",&a[i]);
    MaxSubsequenceSum(a,n);
    system("pause");
    return 0;

    }
    void MaxSubsequenceSum(int a[],int N)
    {
    int Thissum,Maxsum,i,j;

    Maxsum =a[0];
    int l = 0;
    int n = 0;
    int m= 0;
    for(i = 0;i<N;i++)
    {
    if(a[i]<0)
    l++;
    Thissum =0;
    for(j = i;j<N;j++)
    {
    Thissum += a[j];
    if(Thissum > Maxsum)
    {
    Maxsum = Thissum;
    n = i;
    m = j;
    }
    }
    }
    if(l == N)
    std::cout<<0<<std::endl;
    else
    std::cout<<Maxsum<<" "<<a[n]<<" "<<a[m]<<std::endl;
    }

  • 相关阅读:
    linux学习之路第八天(linux文件权限详解)
    linux学习之路第八天(组管理和权限管理)
    python 多线程示例
    python scapy 网卡发包
    python scapy 网卡抓包
    python 返回数组的索引
    MPLS 网络中的 MTU
    mysql 导入导出sql文件
    linux 修改MTU值
    ovs 源mac, 目的src 互换
  • 原文地址:https://www.cnblogs.com/Logic09/p/4146218.html
Copyright © 2011-2022 走看看