zoukankan      html  css  js  c++  java
  • HDU1018 Big Number 斯特林公式

    Big Number

    Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10040    Accepted Submission(s): 4476


    Problem Description
    In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
     

    Input
    Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
     

    Output
    The output contains the number of digits in the factorial of the integers appearing in the input.
     

    Sample Input
    2 10 20
     

    Sample Output
    7 19
     

    Source
     

    Recommend
    JGShining
     

    刚看到题目,第一反应便想到大数,但是看看题目,给出的数据可能 达到 10^7 的级别,这么大的数,求阶乘!  oh,my god! 要知道,10000000 的阶乘有六千万多位。

    还好,我们有公式, log10(n!)=(0.5*log(2*PI*n)+n*log(n)-n)/log(10) , 这里利用了 log10 (N)=ln(N)/ln(10);

    公式的名字是 斯特林公式 维基百科的链接 http://zh.wikipedia.org/wiki/%E6%96%AF%E7%89%B9%E6%9E%97%E5%85%AC%E5%BC%8F

    

    


    #include<stdio.h>
    #include<stdlib.h>
    #include<math.h>
    #include<string.h>
    #include<time.h>
    #define PI 3.1415926
    int main()
    {
        int T;
        scanf("%d",&T);
        while(T--)
        {
            int digits,n;
            scanf("%d",&n);
            if(n==0)  //没有也过了..
            {
                printf("1\n");
                continue;
            }
            digits=(int)((0.5*log(2*PI*n)+n*log(n)-n)/log(10));
            printf("%d\n",digits+1);   //加1是必须的。
        }
        return 0;
    }
    
  • 相关阅读:
    SQL序列键
    SQL日期跟时间值序列
    springboot日志配置
    weblogic10补丁升级与卸载
    idea使用svn报错
    mybatis插入数据并返回主键(oracle)
    UTF-8格式txt文件读取字节前三位问题
    https连接器
    git将本地项目上传码云
    aop的使用
  • 原文地址:https://www.cnblogs.com/Lyush/p/2046803.html
Copyright © 2011-2022 走看看