zoukankan      html  css  js  c++  java
  • HDU1060 Leftmost Digit 数论

    Leftmost Digit

                                                                                         Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                                                  Total Submission(s): 5395    Accepted Submission(s): 2032


    Problem Description
    Given a positive integer N, you should output the leftmost digit of N^N.
     

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single positive integer N(1<=N<=1,000,000,000).
     

    Output
    For each test case, you should output the leftmost digit of N^N.
     

    Sample Input
    2
    3
    4
     

    Sample Output
    2
    2

    Hint

    In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
    In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
     
        以前有做过求x的x次方的最后一位数字是什么,但是这里求最高位的数字是几,初一想,这里的每一位在相乘的过程中对可能对最高位的值有贡献,所以相对求位数求余的求商肯定是不行了。   这里应该对 一个数有这样的理解,一个数是由每一位的基数乘以相对应的权值,例如 123456 , 基数"1"的权值为 10^5,  基数 "2" 的权值为 10^4......所以该题要求的就是最高位的基数。
        对 x^x 取对数,得 x* ln( x )/ ln( 10 ), 现假设这个值为 X.abcdeefg   那么 10^X 就是 最高位对应的权值,10^ 0.abcdefg 就是最高位的基数。注意这里得到的并不是一个整数,为什么呢? 因为这里是强行将后面位的值也转化到最高位上来了,这有点像大数中,如果不满进制却强行进位,显然那样会进给高位一个小数而不是一个天经地义的整数。得到 10^ 0.abcdefg 后,再用 double floor ( double ) 函数取下整就得到最高位的数值大小了。  over...... 想了老半天啊。
    代码如下:
    #include <stdio.h>
    #include <math.h>
    
    
    int T;
    
    int main(  )
    {
        scanf( "%d", &T );
        while( T-- )
        {
            int num;
            scanf( "%d", &num );
            double temp= num* log( num )/ log( 10 );
            double res= temp- floor( temp );
            int ans= ( int )floor( pow( 10, res ) );
            printf( "%d\n", ans );
        }
        return 0;
    }
    
  • 相关阅读:
    高德地图修改背景色
    shell程序的编写
    WPF程序,运行时,结束时,要运行的操作(自动保存,检查单程序)
    android EditText光标位置(定位到最后)
    字体结构的Baseline/Leading/Ascent/Descent的图示
    Java解析xml(转)
    python常用抽象基类1
    airflow之SubDAGs(转载)
    java解析xml(转)
    python内部类
  • 原文地址:https://www.cnblogs.com/Lyush/p/2102563.html
Copyright © 2011-2022 走看看