zoukankan      html  css  js  c++  java
  • Hdoj 1232.畅通工程 题解

    Problem Description

    某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

    Input

    测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
    注意:两个城市之间可以有多条道路相通,也就是说
    3 3
    1 2
    1 2
    2 1
    这种输入也是合法的
    当N为0时,输入结束,该用例不被处理。

    Output

    对每个测试用例,在1行里输出最少还需要建设的道路数目。

    Sample Input

    4 2
    1 3
    4 3
    3 3
    1 2
    1 3
    2 3
    5 2
    1 2
    3 5
    999 0
    0
    

    Sample Output

    1
    0
    2
    998
    
    
    
    HintHint 
    Huge input, scanf is recommended.
    

    Source

    浙大计算机研究生复试上机考试-2005年


    思路

    并查集的简单应用题目,我们只要找出一共有几个块,块数减一就是需要多建设的道路数

    代码

    #include<bits/stdc++.h>
    using namespace std;
    int father[1000];
    void init(int n)
    {
        for(int i=1;i<=n;i++) father[i]=i;
    }
    int find(int x)
    {
        while(father[x]!=x) x=father[x];
        return x;
    }
    void join(int a,int b)
    {
        int t1=find(a);
        int t2=find(b);
        if(t1!=t2) father[t1]=t2;
    }
    int main()
    {
    	int n,m;
    	int a,b;
    	while(cin>>n)
    	{
    	    if(n==0) break;
    	    else
    	    {
    	        cin >> m;
    	        init(n);
    	        for(int i=1;i<=m;i++)
    	        {
    	            cin >> a >> b;
    	            join(a,b);
    	        }
    	        int cnt=0;
    	        for(int i=1;i<=n;i++)
                    if(father[i]==i) cnt++;
                cout << cnt-1 << endl;
    	    }
    	}
    	return 0;
    }
    
  • 相关阅读:
    JDBC的简单笔记
    javascript学习笔记二
    javascript学习一、js的初步了解
    css的简单学习笔记
    c++ 拷贝构造函数
    C++ new delete
    c++ 析构函数
    c++成员初始化和构造函数
    C++ 类和对象浅解
    c++ constexpr
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/10036684.html
Copyright © 2011-2022 走看看