zoukankan      html  css  js  c++  java
  • PTA(Advanced Level)1031.Hello World for U

    Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

    h  d
    e  l
    l  r
    lowo
    

    That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1=n3=max { k | kn2 for all 3≤n2≤N } with n1+n2+n3−2=N.

    Input Specification:

    Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

    Output Specification:

    For each test case, print the input string in the shape of U as specified in the description.

    Sample Input:
    helloworld!
    
    Sample Output:
    h   !
    e   d
    l   l
    lowor
    
    思路
    • 要使得图像尽可能像正方形,且底部边长要(ge)两边边长,由(n_1+n_2+n_3-2 =N)可知(n_1,n_3)要较小,极限情况是(n_1=n_2=n_3),那么如何保证(n_1=n_3le n_2)呢,让(n_1=n_3=(n+2)/2),因为是向下取整的关系,所以一定会有(n_1=n_3le n_2)成立
    代码
    #include<bits/stdc++.h>
    using namespace std;
    
    int main()
    {
    	string s;
    	cin >> s;
    	int n = s.size();
    	int vertical, bottom;
    	vertical = (n + 2) / 3;
    	bottom = n - 2*vertical + 2;
    	
    	int l = 0, r = n - 1;
    	for(int i=0;i<vertical-1;i++)
    	{
    		cout << s[l];
    		for(int j=0;j<bottom-2;j++)	cout << " ";
    		cout << s[r];
    		cout << endl;
    		l++; r--;
    	}
    	for(int i=l;i<=r;i++)
    		cout << s[i];
    	return 0;
    }
    
    
    
    引用

    https://pintia.cn/problem-sets/994805342720868352/problems/994805462535356416

  • 相关阅读:
    [苹果maccms] MACCMS苹果cms宝塔定时任务添加教程说明
    [苹果cmsV10]新版本演员库分类报无权限问题和解决方法!
    CentOS 6.8安装Python2.7.13
    [HOWTO] Install Sphinx for A Script Pro
    A Script Pro nginx URL重写规则无法播放MP4解决方法
    随机跳转
    UI库
    vuex
    vue 数据请求
    vue守卫、储存与路由模式
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/11665373.html
Copyright © 2011-2022 走看看