Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10100).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
思路
- 每读入一个字符就加到
sum
里,最后转为字符串,逐字符输出对应的英文单词就好了
代码
#include<bits/stdc++.h>
using namespace std;
char q[10][10] = {"zero", "one", "two", "three", "four", "five",
"six", "seven", "eight", "nine"};
int main()
{
char ch;
int ans = 0;
while(cin>>ch)
{
ans += ch - '0';
}
string s = to_string(ans);
//cout << ans << endl;
for(int i=0;i<s.size();i++)
{
if(i != s.size() - 1)
cout << q[s[i]-'0'] << " ";
else cout << q[s[i]-'0'];
}
return 0;
}
引用
https://pintia.cn/problem-sets/994805342720868352/problems/994805519074574336