Excel can sort records according to any column. Now you are supposed to imitate this function.
Input Specification:
Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).
Output Specification:
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
Sample Input 1:
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2:
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3:
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
思路
- 仍旧是结构体数组排序的任务,根据
C
取值的不同方式进行排序,对应有三个排序函数cmp
代码
#include<bits/stdc++.h>
using namespace std;
struct student
{
char id[7];
char name[9];
int grade;
}a[100010];
bool cmp1(student a, student b)
{
return strcmp(a.id, b.id) < 0;
} //比较id
bool cmp2(student a, student b)
{
if(strcmp(a.name, b.name) != 0)
return strcmp(a.name, b.name) < 0;
else
return strcmp(a.id, b.id) < 0;
}//比较名字,相同就比较id
bool cmp3(student a, student b)
{
if(a.grade != b.grade)
return a.grade < b.grade;
else
return strcmp(a.id, b.id) < 0;
}//比较分数,相同就比较id
int main()
{
int n, c;
cin >> n >> c;
for(int i=0;i<n;i++)
{
cin >> a[i].id >> a[i].name >> a[i].grade;
}
switch(c)
{
case 1:
sort(a, a+n, cmp1);
break; //执行完一个分支要break
case 2:
sort(a, a+n, cmp2);
break; //执行完一个分支要break
case 3:
sort(a, a+n, cmp3);
}
for(int i=0;i<n;i++)
{
cout << a[i].id << " " << a[i].name << " " <<a[i].grade;
if(i != n-1) cout << endl; //避免输出额外空格
}
return 0;
}
引用
https://pintia.cn/problem-sets/994805342720868352/problems/994805468327690240