zoukankan      html  css  js  c++  java
  • PTA(Advanced Level)1044.Shopping in Mars

    Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

    1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
    2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
    3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

    Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

    If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1⋯D**N (D**i≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print i-j in a line for each pair of ij such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

    If there is no solution, output i-j for pairs of ij such that Di + ... + Dj >M with (Di + ... + DjM) minimized. Again all the solutions must be printed in increasing order of i.

    It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

    Sample Input 1:
    16 15
    3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
    
    Sample Output 1:
    1-5
    4-6
    7-8
    11-11
    
    Sample Input 2:
    5 13
    2 4 5 7 9
    
    Sample Output 2:
    2-4
    4-5
    
    思路
    • 题目大意就是要找连续子序列,使得和为给定的m或尽可能地接近m
    • 都为正数的情况下,连续子序列和具有良好的性质(单调递增),使得二分法变得可行
    代码
    #include<bits/stdc++.h>
    using namespace std;
    int sum[100010];
    
    int find_upper_bound(int l, int r, int x)
    {
    	int left = l, right = r, mid;
    	while(left < right)
    	{
    		mid = (left + right) >> 1;
    		if(sum[mid] > x)  //和超过了x,但是我们此时仍旧没有排除这个位置,因为我们要找的是第一个大于x的位置
    			right = mid;
    		else
    			left = mid + 1;
    	}
    	return left;
    }
    int main()
    {
    	int n, m;
    	cin >> n >> m;
    
    	sum[0] = 0;
    	for(int i=1;i<=n;i++)
    	{
    		cin >> sum[i];
    		sum[i] += sum[i-1];
    	}  //读取数据,记录子序列和,其中sum[i]表示a[1]~a[i]的和
    
    	int nearest = 2100000000;
    	//找最接近的情况
    	for(int i=1;i<=n;i++)
    	{
    		int j = find_upper_bound(i, n+1, sum[i-1] + m);
    		if(sum[j-1] - sum[i-1] == m)
    		{
    			nearest = m;   //最接近的就是m了,也就是说存在连续子序列和为m
    			break;
    		}else if (j <= n &&  sum[j] - sum[i-1] < nearest)
    			nearest = sum[j] - sum[i-1]; //记录最接近的情况
    	}
    	for(int i=1;i<=n;i++)
    	{
             //当nearest为m的时候,回按照i的递增顺序打印出所有答案,如果不是那么只打印出最接近的答案
    		int j = find_upper_bound(i, n+1, sum[i-1] + nearest);
    		if(sum[j-1] - sum[i-1] == nearest)
    			cout << i << '-' << j-1 << endl;
    	}
    	return 0;
    }
    
    引用

    https://pintia.cn/problem-sets/994805342720868352/problems/994805439202443264

  • 相关阅读:
    windows 创建指定大小文件
    python pip命令 报错‘unknow or unsupported command install’
    PyCharm:ModuleNotFoundError: No module named 'selenium'
    毕设图片链接
    本地localhost:端口号(自己设置的Apache的端口号)打不开问题解决了!开心、哭泣
    python之freshman00
    Python之freshman07 面向对象编程jinjie
    Python之freshman08 Socket
    Python之freshman04
    Python之freshman05
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/12028437.html
Copyright © 2011-2022 走看看